summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/tuxanci')
-rw-r--r--games-arcade/tuxanci/ChangeLog10
-rw-r--r--games-arcade/tuxanci/metadata.xml2
-rw-r--r--games-arcade/tuxanci/tuxanci-0.21.0.ebuild63
-rw-r--r--games-arcade/tuxanci/tuxanci-20110429.ebuild73
-rw-r--r--games-arcade/tuxanci/tuxanci-99999999.ebuild (renamed from games-arcade/tuxanci/tuxanci-9999.ebuild)12
5 files changed, 92 insertions, 68 deletions
diff --git a/games-arcade/tuxanci/ChangeLog b/games-arcade/tuxanci/ChangeLog
index 927602dc2e30..32253ba2241c 100644
--- a/games-arcade/tuxanci/ChangeLog
+++ b/games-arcade/tuxanci/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-arcade/tuxanci
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxanci/ChangeLog,v 1.9 2011/04/28 22:07:32 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxanci/ChangeLog,v 1.10 2011/04/28 22:36:10 scarabeus Exp $
+
+*tuxanci-99999999 (28 Apr 2011)
+*tuxanci-20110429 (28 Apr 2011)
+
+ 28 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org> -tuxanci-0.21.0.ebuild,
+ -tuxanci-9999.ebuild, +tuxanci-20110429.ebuild, +tuxanci-99999999.ebuild,
+ metadata.xml:
+ Add new snapshot, bump live version so it is again the latest.
28 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org> tuxanci-0.21.0.ebuild,
tuxanci-9999.ebuild:
diff --git a/games-arcade/tuxanci/metadata.xml b/games-arcade/tuxanci/metadata.xml
index a8479d59d7cf..7a36be46c62c 100644
--- a/games-arcade/tuxanci/metadata.xml
+++ b/games-arcade/tuxanci/metadata.xml
@@ -8,5 +8,7 @@
<herd>games</herd>
<use>
<flag name="sound">Enable sound</flag>
+ <flag name="physfs">Use <pkg>dev-games/physfs</pkg> instead of
+ <pkg>dev-libs/libzip</pkg> to load compressed data.</flag>
</use>
</pkgmetadata>
diff --git a/games-arcade/tuxanci/tuxanci-0.21.0.ebuild b/games-arcade/tuxanci/tuxanci-0.21.0.ebuild
deleted file mode 100644
index 881f614db97f..000000000000
--- a/games-arcade/tuxanci/tuxanci-0.21.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxanci/tuxanci-0.21.0.ebuild,v 1.9 2011/04/28 22:07:32 scarabeus Exp $
-
-EAPI="2"
-
-inherit eutils cmake-utils games
-
-DESCRIPTION="Tuxanci is first cushion shooter inspired by game Bulanci."
-HOMEPAGE="http://www.tuxanci.org/"
-SRC_URI="http://download.${PN}.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="alsa debug dedicated nls"
-# alsa is used only when building client
-
-RDEPEND="!dedicated? (
- >=media-libs/libsdl-1.2.10[X]
- >=media-libs/sdl-ttf-2.0.7[X]
- >=media-libs/sdl-image-1.2.6-r1[png]
- alsa? (
- >=media-libs/sdl-mixer-1.2.7[vorbis]
- )
- )
- dev-libs/zziplib"
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.6.0
- nls? ( sys-devel/gettext )"
-
-src_configure() {
- local mycmakeargs
- use alsa || mycmakeargs="${mycmakeargs} -DNO_Audio=1"
- use debug && mycmakeargs="${mycmakeargs} -DDebug=1"
- use dedicated && mycmakeargs="${mycmakeargs} -DServer=1"
- use nls && mycmakeargs="${mycmakeargs} -DNLS=1"
- # This cant be quoted due to cmake nature.
- # Read as: quote it and it wont compile.
- mycmakeargs="${mycmakeargs} -DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}
- -DCMAKE_DATA_PATH=${GAMES_DATADIR}
- -DCMAKE_LOCALE_PATH=${GAMES_DATADIR_BASE}/locale/
- -DCMAKE_DOC_PATH=${GAMES_DATADIR_BASE}/doc/
- -DCMAKE_CONF_PATH=${GAMES_SYSCONFDIR} -DLIB_INSTALL_DIR=$(games_get_libdir)
- -DCMAKE_BUILD_TYPE=Release"
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- local MY_PN
- use dedicated && MY_PN=${PN}-server || MY_PN=${PN}
-
- cmake-utils_src_install
- dosym "${GAMES_BINDIR}"/${MY_PN}-${PV} "${GAMES_BINDIR}"/${MY_PN}
- doicon data/${PN}.svg
- # we compile our desktop file
- domenu data/${PN}.desktop
- prepgamesdirs
-}
diff --git a/games-arcade/tuxanci/tuxanci-20110429.ebuild b/games-arcade/tuxanci/tuxanci-20110429.ebuild
new file mode 100644
index 000000000000..2536874bcda7
--- /dev/null
+++ b/games-arcade/tuxanci/tuxanci-20110429.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxanci/tuxanci-20110429.ebuild,v 1.1 2011/04/28 22:36:10 scarabeus Exp $
+
+EAPI=3
+
+[[ ${PV} = 9999* ]] && GIT="git-2"
+EGIT_REPO_URI="git://repo.or.cz/tuxanci.git"
+
+inherit games cmake-utils ${GIT}
+
+DESCRIPTION="Tuxanci is first tux shooter inspired by game Bulanci."
+HOMEPAGE="http://www.tuxanci.org/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="debug dedicated +ipv6 nls opengl physfs +sound"
+
+# >=x11-libs/cairo-1.8.8[X,svg]
+RDEPEND="
+ !dedicated? (
+ >=media-libs/fontconfig-2.7.0
+ media-libs/libsdl[X,opengl?]
+ media-libs/sdl-ttf[X]
+ >=media-libs/sdl-image-1.2.10[png]
+ sound? (
+ >=media-libs/sdl-mixer-1.2.11[vorbis]
+ )
+ )
+ physfs? ( dev-games/physfs[zip] )
+ !physfs? ( >=dev-libs/libzip-0.9 )
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local mycmakeargs+=(
+ $(cmake-utils_use_with sound AUDIO)
+ $(cmake-utils_use_build dedicated SERVER)
+ $(cmake-utils_use_with nls)
+ $(cmake-utils_use_with physfs)
+ $(cmake-utils_use_with opengl)
+ $(cmake-utils_use_enable ipv6)
+ $(cmake-utils_use_enable debug)
+ )
+
+ mycmakeargs+=(
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DCMAKE_INSTALL_ICONDIR=${GAMES_DATADIR_BASE}/pixmaps/"
+ "-DCMAKE_INSTALL_DESKTOPDIR=${GAMES_DATADIR_BASE}/applications/"
+ "-DCMAKE_DATA_PATH=${GAMES_DATADIR}"
+ "-DCMAKE_LOCALE_PATH=${GAMES_DATADIR_BASE}/locale/"
+ "-DCMAKE_DOC_PATH=${GAMES_DATADIR_BASE}/doc/${PF}"
+ "-DCMAKE_CONF_PATH=${GAMES_SYSCONFDIR}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ prepgamesdirs
+}
diff --git a/games-arcade/tuxanci/tuxanci-9999.ebuild b/games-arcade/tuxanci/tuxanci-99999999.ebuild
index 33ab21021264..ed7de6d853ad 100644
--- a/games-arcade/tuxanci/tuxanci-9999.ebuild
+++ b/games-arcade/tuxanci/tuxanci-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxanci/tuxanci-9999.ebuild,v 1.3 2011/04/28 22:07:32 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxanci/tuxanci-99999999.ebuild,v 1.1 2011/04/28 22:36:10 scarabeus Exp $
EAPI=3
@@ -21,7 +21,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="debug dedicated +ipv6 nls opengl +sound"
+IUSE="debug dedicated +ipv6 nls opengl physfs +sound"
# >=x11-libs/cairo-1.8.8[X,svg]
RDEPEND="
@@ -34,16 +34,20 @@ RDEPEND="
>=media-libs/sdl-mixer-1.2.11[vorbis]
)
)
- >=dev-libs/libzip-0.9"
+ physfs? ( dev-games/physfs[zip] )
+ !physfs? ( >=dev-libs/libzip-0.9 )
+"
DEPEND="${RDEPEND}
dev-util/pkgconfig
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+"
src_configure() {
local mycmakeargs+=(
$(cmake-utils_use_with sound AUDIO)
$(cmake-utils_use_build dedicated SERVER)
$(cmake-utils_use_with nls)
+ $(cmake-utils_use_with physfs)
$(cmake-utils_use_with opengl)
$(cmake-utils_use_enable ipv6)
$(cmake-utils_use_enable debug)