summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/mrrescue/mrrescue-1.02b.ebuild')
-rw-r--r--games-arcade/mrrescue/mrrescue-1.02b.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-arcade/mrrescue/mrrescue-1.02b.ebuild b/games-arcade/mrrescue/mrrescue-1.02b.ebuild
new file mode 100644
index 000000000000..e57f42dd8a2e
--- /dev/null
+++ b/games-arcade/mrrescue/mrrescue-1.02b.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/mrrescue/mrrescue-1.02b.ebuild,v 1.1 2013/12/15 13:16:57 hasufell Exp $
+
+EAPI=5
+
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Arcade styled 2d action game centered around evacuating civilians from burning buildings"
+HOMEPAGE="http://tangramgames.dk/games/mrrescue/"
+SRC_URI="https://github.com/SimonLarsen/mrrescue/releases/download/v${PV}/${P}-love.zip
+ http://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="CC-BY-SA-3.0 MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="games-engines/love:0"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${P}-love
+
+src_install() {
+ local dir=${GAMES_DATADIR}/love/${PN}
+
+ exeinto "${dir}"
+ doexe ${PN}.love
+
+ dodoc README.txt
+
+ doicon -s 64 "${DISTDIR}"/${PN}.png
+ games_make_wrapper ${PN} "love ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}