summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/briquolo/briquolo-0.5.1.ebuild')
-rw-r--r--games-arcade/briquolo/briquolo-0.5.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-arcade/briquolo/briquolo-0.5.1.ebuild b/games-arcade/briquolo/briquolo-0.5.1.ebuild
new file mode 100644
index 000000000000..d115aa544ff2
--- /dev/null
+++ b/games-arcade/briquolo/briquolo-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/briquolo/briquolo-0.5.1.ebuild,v 1.1 2005/02/02 06:24:15 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Breakout with 3D representation based on OpenGL"
+HOMEPAGE="http://briquolo.free.fr/en/index.html"
+SRC_URI="http://briquolo.free.fr/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="nls"
+
+DEPEND="virtual/opengl
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/libpng
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable nls) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+ prepgamesdirs
+}