summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild')
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild
index 2da1b1eaa806..58d77fd6b3ef 100644
--- a/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild
+++ b/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild,v 1.3 2010/06/22 18:43:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild,v 1.4 2011/03/25 21:25:47 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
PYTHON_USE_WITH_OR="berkdb gdbm"
PYTHON_USE_WITH_OPT="test"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
-inherit eutils distutils
+inherit distutils
FILEVER="46528"
@@ -19,13 +22,19 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="bazaar git test"
-DEPEND="dev-lang/python
- >=dev-vcs/subversion-1.0.9"
+DEPEND=">=dev-vcs/subversion-1.0.9"
RDEPEND="${DEPEND}
bazaar? ( >=dev-vcs/bzr-1.13 )
git? ( >=dev-vcs/git-1.5.4.4 )
dev-vcs/rcs"
+PYTHON_MODNAME="cvs2svn_lib cvs2svn_rcsparse"
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r 2 .
+}
+
src_compile() {
distutils_src_compile
emake man
@@ -41,10 +50,15 @@ src_install() {
src_test() {
# Need this because subversion is localized, but the tests aren't
export LC_ALL=C
- python -W ignore run-tests.py || die "tests failed"
+
+ testing() {
+ "$(PYTHON)" -W ignore run-tests.py
+ }
+ python_execute_function testing
}
pkg_postinst() {
+ distutils_pkg_postinst
elog "Additional scripts and examples have been installed to:"
elog " /usr/share/${PN}/"
}