summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cwdiff/ChangeLog9
-rw-r--r--dev-util/cwdiff/cwdiff-0.2.7.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-util/cwdiff/ChangeLog b/dev-util/cwdiff/ChangeLog
index 21f280bd3486..25bbb8f2806a 100644
--- a/dev-util/cwdiff/ChangeLog
+++ b/dev-util/cwdiff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cwdiff
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cwdiff/ChangeLog,v 1.8 2014/03/13 20:25:28 ottxor Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cwdiff/ChangeLog,v 1.9 2015/03/09 22:51:50 ottxor Exp $
+
+*cwdiff-0.2.7 (09 Mar 2015)
+
+ 09 Mar 2015; Christoph Junghans <ottxor@gentoo.org> +cwdiff-0.2.7.ebuild:
+ version bump
13 Mar 2014; Christoph Junghans <ottxor@gentoo.org> cwdiff-0.2.6.ebuild:
added ~x64-macos (tested by me)
diff --git a/dev-util/cwdiff/cwdiff-0.2.7.ebuild b/dev-util/cwdiff/cwdiff-0.2.7.ebuild
new file mode 100644
index 000000000000..71c1e5331833
--- /dev/null
+++ b/dev-util/cwdiff/cwdiff-0.2.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cwdiff/cwdiff-0.2.7.ebuild,v 1.1 2015/03/09 22:51:50 ottxor Exp $
+
+EAPI=5
+
+DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
+HOMEPAGE="http://code.google.com/p/cj-overlay/source/browse/cwdiff?repo=evergreens"
+SRC_URI="http://downloads.cj-overlay.googlecode.com/hg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x64-macos ~x86-macos"
+IUSE="a2ps mercurial"
+
+DEPEND=""
+RDEPEND="
+ sys-apps/sed
+ app-shells/bash
+ app-text/wdiff
+ sys-apps/diffutils
+ a2ps? ( app-text/a2ps )
+ mercurial? ( dev-vcs/mercurial )
+ "
+
+src_install () {
+ dobin "${PN}"
+ if use mercurial ; then
+ insinto /etc/mercurial/hgrc.d
+ doins hgrc.d/"${PN}".rc
+ fi
+}