summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pccts')
-rw-r--r--dev-util/pccts/ChangeLog8
-rw-r--r--dev-util/pccts/files/pccts-1.33.33-gentoo.diff12
-rw-r--r--dev-util/pccts/pccts-1.33.33-r1.ebuild71
3 files changed, 84 insertions, 7 deletions
diff --git a/dev-util/pccts/ChangeLog b/dev-util/pccts/ChangeLog
index f9983c43d7a5..7297f2382cb7 100644
--- a/dev-util/pccts/ChangeLog
+++ b/dev-util/pccts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/pccts
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pccts/ChangeLog,v 1.29 2010/01/15 21:48:29 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pccts/ChangeLog,v 1.30 2010/09/18 20:55:59 jer Exp $
+
+*pccts-1.33.33-r1 (18 Sep 2010)
+
+ 18 Sep 2010; Jeroen Roovers <jer@gentoo.org> +pccts-1.33.33-r1.ebuild,
+ files/pccts-1.33.33-gentoo.diff:
+ Respect LDFLAGS (bug #335990), CFLAGS. Clean up patch.
15 Jan 2010; Christian Faulhammer <fauli@gentoo.org> pccts-1.33.33.ebuild:
Transfer Prefix keywords
diff --git a/dev-util/pccts/files/pccts-1.33.33-gentoo.diff b/dev-util/pccts/files/pccts-1.33.33-gentoo.diff
index 5835c807104c..2fab4f9cba38 100644
--- a/dev-util/pccts/files/pccts-1.33.33-gentoo.diff
+++ b/dev-util/pccts/files/pccts-1.33.33-gentoo.diff
@@ -1,5 +1,5 @@
---- pccts/support/genmk/genmk.c Fri Aug 3 17:12:51 2001
-+++ pccts/support/genmk/genmk-gentoo.c Fri Aug 3 17:12:14 2001
+--- a/support/genmk/genmk.c Fri Aug 3 17:12:51 2001
++++ b/support/genmk/genmk.c Fri Aug 3 17:12:14 2001
@@ -7,6 +7,11 @@
* U of MN
*/
@@ -47,8 +47,8 @@
printf("ANTLR = $(BIN)%santlr\n", DirectorySymbol);
printf("DLG = $(BIN)%sdlg\n", DirectorySymbol);
if (num_sors>0) printf("SOR = $(BIN)%ssor\n", DirectorySymbol);
---- pccts/sorcerer/lib/sorlist.c 1999-06-30 03:15:56.000000000 +0200
-+++ pccts/sorcerer/lib/sorlist.c.new 2003-05-23 11:11:09.000000000 +0200
+--- a/sorcerer/lib/sorlist.c 1999-06-30 03:15:56.000000000 +0200
++++ b/sorcerer/lib/sorlist.c 2003-05-23 11:11:09.000000000 +0200
@@ -28,6 +28,7 @@
*/
#include <stdio.h>
@@ -57,8 +57,8 @@
#ifdef PCCTS_USE_STDARG
#include <stdarg.h>
---- pccts/sorcerer/lib/sintstack.c 1999-06-30 15:08:06.000000000 +0200
-+++ pccts/sorcerer/lib/sintstack.c.new 2003-05-23 12:54:26.000000000 +0200
+--- a/sorcerer/lib/sintstack.c 1999-06-30 15:08:06.000000000 +0200
++++ b/sorcerer/lib/sintstack.c 2003-05-23 12:54:26.000000000 +0200
@@ -28,6 +28,7 @@
*/
#include <stdio.h>
diff --git a/dev-util/pccts/pccts-1.33.33-r1.ebuild b/dev-util/pccts/pccts-1.33.33-r1.ebuild
new file mode 100644
index 000000000000..30cdfa7c624f
--- /dev/null
+++ b/dev-util/pccts/pccts-1.33.33-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pccts/pccts-1.33.33-r1.ebuild,v 1.1 2010/09/18 20:55:59 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Purdue Compiler Construction Tool Set is an embedded C/C++ parser generator"
+HOMEPAGE="http://www.polhode.com/"
+SRC_URI="http://www.polhode.com/pccts133mr33.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PF}-gentoo.diff
+ sed -i support/genmk/makefile \
+ -e 's| -o genmk| $(COPT) &|g' \
+ || die "sed support/genmk/makefile"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ COPT="${CFLAGS} ${LDFLAGS}" \
+ || die "compilation failed"
+}
+
+src_install() {
+ # main binaries
+ dobin bin/{antlr,dlg,genmk,sor} || die
+
+ # .c and .cpp files go into /usr/include/pccts also,
+ # because genmk looks for them for being included in output-files
+ # (which are c/c++) generated from grammar-files
+ # right now i include _everything_ just to make sure
+ # it doesn't break pccts-based projects
+ #
+ # if i dive further into the details of genmk.c
+ # it should be possible to put that stuff into /usr/share/pccts
+ #
+ # the M$ and MAC specific stuff gets _not_ included
+ #
+ # main includes
+ insinto /usr/include/pccts
+ doins h/*.{h,c,cpp} || die
+
+ # sorcerer includes
+ insinto /usr/include/pccts/sorcerer
+ doins sorcerer/h/*.h || die
+
+ # sorcerer libraries
+ insinto /usr/include/pccts/sorcerer/lib
+ doins sorcerer/lib/*.{h,c,cpp} || die
+
+ # documentation
+ # leaving out the M$ and MAC stuff
+ dodoc CHANGES* KNOWN_PROBLEMS* README RIGHTS history.txt history.ps
+ dodoc sorcerer/README sorcerer/UPDATES
+
+ # manual pages
+ doman dlg/dlg.1 antlr/antlr.1
+}