summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lockrun/lockrun-2.ebuild')
-rw-r--r--dev-util/lockrun/lockrun-2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/lockrun/lockrun-2.ebuild b/dev-util/lockrun/lockrun-2.ebuild
new file mode 100644
index 000000000000..433bdd218e85
--- /dev/null
+++ b/dev-util/lockrun/lockrun-2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/lockrun/lockrun-2.ebuild,v 1.1 2008/02/05 18:22:37 caleb Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lockrun - runs cronjobs with overrun protection"
+HOMEPAGE="http://www.unixwiz.net/tools/lockrun.html"
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${FILESDIR}"/lockrun.c "${S}"/lockrun.c
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} lockrun.c -o lockrun
+}
+
+src_install () {
+ dodir /usr/bin
+ cp lockrun "${D}"/usr/bin
+}