summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/hevea/hevea-1.10.ebuild')
-rw-r--r--dev-tex/hevea/hevea-1.10.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-tex/hevea/hevea-1.10.ebuild b/dev-tex/hevea/hevea-1.10.ebuild
deleted file mode 100644
index 558c77ddc267..000000000000
--- a/dev-tex/hevea/hevea-1.10.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/hevea/hevea-1.10.ebuild,v 1.7 2009/12/27 11:55:03 armin76 Exp $
-
-EAPI="2"
-
-inherit eutils multilib
-
-IUSE="+ocamlopt"
-
-DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
-HOMEPAGE="http://pauillac.inria.fr/~maranget/hevea/"
-SRC_URI="ftp://ftp.inria.fr/INRIA/moscova/hevea/${P}.tar.gz"
-
-LICENSE="QPL"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 sparc x86"
-
-DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- rm -f config.sh
- emake PREFIX=/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/hevea" LATEXLIBDIR="/usr/$(get_libdir)/hevea" config.sh || die "Failed to create config.sh"
- if use ocamlopt; then
- emake PREFIX=/usr || die "Failed to build native code binaries"
- else
- emake PREFIX=/usr TARGET=byte || die "Failed to build bytecode binaries"
- fi
-}
-
-src_install() {
- if use ocamlopt; then
- emake DESTDIR="${D}" PREFIX=/usr install || die "Install failed"
- else
- emake DESTDIR="${D}" PREFIX=/usr TARGET=byte install || die "Install failed"
- fi
-
- doenvd "${FILESDIR}"/99hevea
-
- dodoc README CHANGES
-}