summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/text-format/ChangeLog5
-rw-r--r--dev-ruby/text-format/text-format-0.64.ebuild16
2 files changed, 17 insertions, 4 deletions
diff --git a/dev-ruby/text-format/ChangeLog b/dev-ruby/text-format/ChangeLog
index b303fb8ef987..430a1607573f 100644
--- a/dev-ruby/text-format/ChangeLog
+++ b/dev-ruby/text-format/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/text-format
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-format/ChangeLog,v 1.5 2004/06/25 02:05:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-format/ChangeLog,v 1.6 2004/09/07 09:09:39 usata Exp $
+
+ 07 Sep 2004; Mamoru KOMACHI <usata@gentoo.org> text-format-0.64.ebuild:
+ Added src_test(). Stable on x86 and ppc.
11 Apr 2004; David Holm <dholm@gentoo.org> text-format-0.64.ebuild:
Added to ~ppc.
diff --git a/dev-ruby/text-format/text-format-0.64.ebuild b/dev-ruby/text-format/text-format-0.64.ebuild
index 7a25a54960ff..d4dd0fd16bbb 100644
--- a/dev-ruby/text-format/text-format-0.64.ebuild
+++ b/dev-ruby/text-format/text-format-0.64.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-format/text-format-0.64.ebuild,v 1.4 2004/07/14 22:18:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-format/text-format-0.64.ebuild,v 1.5 2004/09/07 09:09:39 usata Exp $
-inherit eutils
+inherit eutils ruby
DESCRIPTION="Text::Format provides strong text formatting capabilities to Ruby"
HOMEPAGE="http://www.halostatue.ca/ruby/Text__Format.html"
@@ -10,9 +10,10 @@ SRC_URI="http://www.halostatue.ca/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ppc"
IUSE=""
DEPEND="virtual/ruby"
+USE_RUBY="any"
src_unpack() {
unpack ${A}
@@ -20,9 +21,18 @@ src_unpack() {
epatch ${FILESDIR}/${P}-prefix.diff
}
+src_compile() {
+ return
+}
+
src_install() {
ruby install.rb --prefix=${D}/usr || die
dohtml -r doc/*
dodoc Changelog
}
+
+src_test() {
+ cd tests
+ ruby unit_tests.rb || die "unit_tests.rb failed."
+}