summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild')
-rw-r--r--dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild14
1 files changed, 2 insertions, 12 deletions
diff --git a/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild b/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild
index 769d25381e29..eff7f378be00 100644
--- a/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild
+++ b/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild,v 1.1 2009/12/20 21:20:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild,v 1.2 2009/12/20 22:20:30 flameeyes Exp $
EAPI="2"
USE_RUBY="ruby18 ruby19"
@@ -18,19 +18,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-# This should in theory work with the test-unit from Ruby 1.8 as well,
-# but since mocha seem to prefer the gem, we're just going to depend
-# on the new version.
-#
-# And yes it's a runtime dependency.
-ruby_add_rdepend dev-ruby/test-unit
-
+ruby_add_rdepend virtual/ruby-test-unit
ruby_add_bdepend test dev-ruby/mocha
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${P}-test-unit.patch
-}
-
all_ruby_install() {
all_fakegem_install