summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/simple_oauth/simple_oauth-0.2.0.ebuild')
-rw-r--r--dev-ruby/simple_oauth/simple_oauth-0.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/simple_oauth/simple_oauth-0.2.0.ebuild b/dev-ruby/simple_oauth/simple_oauth-0.2.0.ebuild
new file mode 100644
index 000000000000..a73e1df08b98
--- /dev/null
+++ b/dev-ruby/simple_oauth/simple_oauth-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/simple_oauth/simple_oauth-0.2.0.ebuild,v 1.1 2012/12/04 07:22:27 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simply builds and verifies OAuth headers."
+HOMEPAGE="https://github.com/laserlemon/simple_oauth"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_test() {
+ export CI=true
+ each_fakegem_test
+}