summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/libxml/libxml-2.0.5.ebuild')
-rw-r--r--dev-ruby/libxml/libxml-2.0.5.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-ruby/libxml/libxml-2.0.5.ebuild b/dev-ruby/libxml/libxml-2.0.5.ebuild
deleted file mode 100644
index 3ee3c4bc5c02..000000000000
--- a/dev-ruby/libxml/libxml-2.0.5.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.0.5.ebuild,v 1.9 2012/05/01 18:24:15 armin76 Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_NAME="libxml-ruby"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
-HOMEPAGE="http://libxml.rubyforge.org"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="amd64 hppa ~ppc ~ppc64 x86"
-IUSE=""
-
-RDEPEND="${RDEPEND} dev-libs/libxml2"
-DEPEND="${DEPEND} dev-libs/libxml2"
-
-all_ruby_prepare() {
- # Remove grancher tasks only needed for publishing the website
- sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
-
- # We don't have the hanna template available.
- sed -i -e 's/hanna/rake/' Rakefile || die
-
- # Remove rake-compiler bits since we don't use it
- sed -i -e '/extensiontask/d' -e '/ExtensionTask/,/end/d' -e '/GemPackageTask/,/end/d' Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext/libxml extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -C ext/libxml
- cp ext/libxml/libxml_ruby.so lib/ || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib -r test/test_helper.rb test/test_suite.rb || die
-}