summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-levenshtein/python-levenshtein-0.10.ebuild')
-rw-r--r--dev-python/python-levenshtein/python-levenshtein-0.10.ebuild42
1 files changed, 28 insertions, 14 deletions
diff --git a/dev-python/python-levenshtein/python-levenshtein-0.10.ebuild b/dev-python/python-levenshtein/python-levenshtein-0.10.ebuild
index 221e2aa76781..9aa755f2f976 100644
--- a/dev-python/python-levenshtein/python-levenshtein-0.10.ebuild
+++ b/dev-python/python-levenshtein/python-levenshtein-0.10.ebuild
@@ -1,30 +1,44 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-levenshtein/python-levenshtein-0.10.ebuild,v 1.5 2009/01/31 23:46:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-levenshtein/python-levenshtein-0.10.ebuild,v 1.6 2010/07/18 15:07:29 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
-MY_P=${P/l/L}
-S=${WORKDIR}/${MY_P}
+MY_PN="python-Levenshtein"
+MY_P="${MY_PN}-${PV}"
DESCRIPTION="Levenshtein contains functions for fast computation of Levenshtein (edit) distance, and edit operations"
-SRC_URI="http://trific.ath.cx/Ftp//python/levenshtein/${MY_P}.tar.bz2"
HOMEPAGE="http://trific.ath.cx/resources/python/levenshtein/"
-IUSE="doc"
+SRC_URI="http://trific.ath.cx/Ftp//python/levenshtein/${MY_P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
-DEPEND="virtual/python"
+S="${WORKDIR}/${MY_P}"
-src_unpack(){
- unpack ${A}
- use doc && ( cp ${FILESDIR}/genextdoc.py ${T}
- chmod +x ${T}/genextdoc.py )
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH="$(ls -d build-$(PYTHON -f --ABI)/lib.*)" "$(PYTHON -f)" "${FILESDIR}/genextdoc.py" Levenshtein || die "Generation of documentation failed"
+ fi
}
-src_install(){
+src_install() {
distutils_src_install
- use doc && ( ${T}/genextdoc.py Levenshtein
- dohtml Levenshtein.html )
+
+ if use doc; then
+ dohtml Levenshtein.html || die "Installation of documentation failed"
+ fi
}