summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyasn1/pyasn1-0.1.2.ebuild')
-rw-r--r--dev-python/pyasn1/pyasn1-0.1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyasn1/pyasn1-0.1.2.ebuild b/dev-python/pyasn1/pyasn1-0.1.2.ebuild
new file mode 100644
index 000000000000..03236d320cc4
--- /dev/null
+++ b/dev-python/pyasn1/pyasn1-0.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyasn1/pyasn1-0.1.2.ebuild,v 1.1 2012/03/02 09:53:38 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="ASN.1 library for Python"
+HOMEPAGE="http://pyasn1.sourceforge.net/ http://pypi.python.org/pypi/pyasn1"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+DOCS="CHANGES README THANKS TODO"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib:." "$(PYTHON)" test/suite.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ dohtml doc/* || die "dohtml failed"
+}