summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/decorator')
-rw-r--r--dev-python/decorator/ChangeLog6
-rw-r--r--dev-python/decorator/decorator-3.1.2.ebuild41
2 files changed, 5 insertions, 42 deletions
diff --git a/dev-python/decorator/ChangeLog b/dev-python/decorator/ChangeLog
index aa87e69d6fa7..18c297de1180 100644
--- a/dev-python/decorator/ChangeLog
+++ b/dev-python/decorator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/decorator
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/ChangeLog,v 1.21 2010/08/12 01:03:03 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/ChangeLog,v 1.22 2010/09/13 15:07:17 arfrever Exp $
+
+ 13 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -decorator-3.1.2.ebuild:
+ Delete.
12 Aug 2010; Joseph Jezak <josejx@gentoo.org> decorator-3.2.0.ebuild:
Marked ppc stable for bug #325901.
diff --git a/dev-python/decorator/decorator-3.1.2.ebuild b/dev-python/decorator/decorator-3.1.2.ebuild
deleted file mode 100644
index 0e49bdcbf0fb..000000000000
--- a/dev-python/decorator/decorator-3.1.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/decorator-3.1.2.ebuild,v 1.8 2010/05/27 17:01:55 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="Simplifies the usage of decorators for the average programmer"
-HOMEPAGE="http://pypi.python.org/pypi/decorator"
-SRC_URI="http://pypi.python.org/packages/source/d/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND=""
-RESTRICT_PYTHON_ABIS="3.*"
-
-DOCS="CHANGES.txt README.txt"
-PYTHON_MODNAME="decorator.py"
-
-src_test() {
- # multiprocessing module is available only in Python >=2.6, and isn't used anyway.
- sed -i -e '/multiprocessing/d' documentation.py || die
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" documentation.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- if use doc; then
- dodoc documentation.pdf || die "dodoc pdf doc failed"
- dohtml documentation.html || die "dohtml html doc failed"
- fi
-}