summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.16.ebuild')
-rw-r--r--dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.16.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.16.ebuild b/dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.16.ebuild
new file mode 100644
index 000000000000..9d9a9629541d
--- /dev/null
+++ b/dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.16.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.16.ebuild,v 1.1 2007/11/19 18:34:37 ian Exp $
+
+inherit perl-module
+
+DESCRIPTION="Test::WWW::Mechanize is a subclass of WWW::Mechanize that
+incorporates features for web application testing"
+SRC_URI="mirror://cpan/authors/id/P/PE/PETDANCE/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/~petdance/${P}/"
+IUSE=""
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+#SRC_TEST="do"
+
+DEPEND=">=dev-perl/WWW-Mechanize-1.24
+ dev-perl/Carp-Assert-More
+ >=dev-perl/HTTP-Server-Simple-0.07
+ dev-perl/URI
+ >=dev-perl/Test-LongString-0.07
+ dev-lang/perl"
+
+src_compile() {
+ echo "y" | perl-module_src_compile
+}