summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/geoip/geoip-1.4.3.ebuild')
-rw-r--r--dev-libs/geoip/geoip-1.4.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/geoip/geoip-1.4.3.ebuild b/dev-libs/geoip/geoip-1.4.3.ebuild
new file mode 100644
index 000000000000..1374a9e5e3b1
--- /dev/null
+++ b/dev-libs/geoip/geoip-1.4.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/geoip-1.4.3.ebuild,v 1.1 2007/12/26 17:47:07 pva Exp $
+
+inherit autotools eutils libtool
+
+MY_P="${P/geoip/GeoIP}"
+DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
+HOMEPAGE="http://www.maxmind.com/geoip/api/c.shtml"
+SRC_URI="http://www.maxmind.com/download/geoip/api/c/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # FreeBSD requires this
+ elibtoolize
+}
+
+src_compile() {
+ econf --enable-shared || die "econf failed"
+ # both parallel make and parallel make install explodes atm
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+}