summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog13
-rw-r--r--dev-libs/boost/Manifest4
-rw-r--r--dev-libs/boost/boost-1.31.0_alpha1.ebuild108
-rw-r--r--dev-libs/boost/files/digest-boost-1.31.0_alpha11
4 files changed, 123 insertions, 3 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 86ebd637fdf4..4fec7ba21d14 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,8 +1,17 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.6 2003/08/25 00:58:02 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.7 2003/12/19 16:44:07 george Exp $
-*boost-1.30.0 (24 Aug 2003)
+*boost-1.31.0_alpha1 (18 Dec 2003)
+
+ 18 Dec 2003; George Shapovalov <george@gentoo.org> boost-1.31.0_alpha1.ebuild :
+ SInce 1.30 stopped working with python 2.3 (see #35268) and 1.31 is not yet out
+ I am adding this cvs snapshot. Note: !!!do not just copy this one over!!!
+ Adjust a few vars inside if you do update it!
+ This one also incorporates build tools installation from #35718 (thanks to
+ Chris Mayo <mayo@clara.co.uk> for suggestion).
+
+*boost-1.30.2 (24 Aug 2003)
24 Aug 2003; George Shapovalov <george@gentoo.org> boost-1.30.2.ebuild :
looks like I got stuck with this ebuild :),
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index 6750ea9d3450..31903f8f7184 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -1,7 +1,9 @@
-MD5 57cde67b60dd2ecbc56050b4473c58e9 ChangeLog 1369
MD5 4537d46888da386ec78522e8def821c7 boost-1.29.0.ebuild 1437
+MD5 c3fd5e326973a985b9257fddbbd34590 boost-1.31.0_alpha1.ebuild 3217
MD5 47cc0eb1fd0be0e7b300c2433f3da645 boost-1.30.0.ebuild 2997
+MD5 3a8c0f9e33aa84a1e756da799b78642a ChangeLog 1823
MD5 226122b504f12a7caf065d543b5218ed boost-1.30.2.ebuild 2980
+MD5 487e6d82cebac2a4027fc907bd1df56e files/digest-boost-1.31.0_alpha1 67
MD5 ed187a2b2048776a7e5b27060d96938c files/digest-boost-1.29.0 65
MD5 2b36d47323b021671d391600501685cc files/digest-boost-1.30.0 66
MD5 a09c431deb3a25504525921685cd0e57 files/digest-boost-1.30.2 66
diff --git a/dev-libs/boost/boost-1.31.0_alpha1.ebuild b/dev-libs/boost/boost-1.31.0_alpha1.ebuild
new file mode 100644
index 000000000000..e858a6d34b91
--- /dev/null
+++ b/dev-libs/boost/boost-1.31.0_alpha1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.31.0_alpha1.ebuild,v 1.1 2003/12/19 16:44:07 george Exp $
+
+MyPV="2003d18"
+
+DESCRIPTION="Boost provides free peer-reviewed portable C++ source libraries."
+HOMEPAGE="http://www.boost.org"
+#SRC_URI="http://easynews.dl.sourceforge.net/sourceforge/boost/boost-${PV}.tar.bz2"
+SRC_URI="mirror://gentoo/${PN}-${MyPV}.tar.bz2"
+
+S=${WORKDIR}/${PN}
+
+LICENSE="freedist"
+KEYWORDS="~x86 ~ppc"
+SLOT="1"
+IUSE="icc"
+
+# This would be a good place for someone to figure out how to get
+# boost to build nicely with icc, as it's documented to be doable.
+
+DEPEND="virtual/glibc"
+RDEPEND=">=dev-util/yacc-1.9.1-r1
+ >=dev-lang/python-2.2.1
+ icc? ( >=dev-lang/icc-7.1 )"
+
+src_compile() {
+ local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
+ local BOOST_TOOLSET
+
+ if [ "`use icc`" ] ; then
+ BOOST_TOOLSET="intel-linux"
+ else
+ BOOST_TOOLSET="gcc"
+ fi
+
+ # Build bjam, a jam variant, which is used instead of make
+ cd ${S}/tools/build/jam_src
+ ./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
+ cd ${S}
+
+ if [ "`use icc`" ] ; then
+ ./tools/build/jam_src/bin.linux${ARCH}/bjam -j2 \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sINTEL_LINUX_VERSION="70" || die "Failed to build boost libraries."
+ else
+ ./tools/build/jam_src/bin.linux${ARCH}/bjam ${MAKEOPTS} \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET}
+
+ einfo "Don't worry if there are a few (probably 6) failures above."
+ einfo "Some targets merely need to be combined. Here goes:"
+
+ ./tools/build/jam_src/bin.linux${ARCH}/bjam \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET} || die "Failed to build boost libraries."
+ fi
+}
+
+src_install () {
+ # Unfortunately boost doesn't provide a standard way to
+ # install itself. So it's done "manually" here.
+
+ # install libraries
+ find libs -type f -name \*.a -exec dolib.a {} \;
+ find libs -type f -name \*.so -exec dolib.so {} \;
+
+ # install source/header files
+
+ find boost -type f \
+ -exec install -D -m0644 {} ${D}/usr/include/{} \;
+
+ # install build tools
+ cd tools/build
+ #do_whatever is too limiting here, need to move bunch of different stuff recursively
+ dodir /usr/share/${PN}
+ cp -a b* c* index.html v1/ v2/ ${D}/usr/share/${PN}
+ cd ${S}
+
+ # install documentation
+ dodoc README
+ dohtml index.htm google_logo_40wht.gif c++boost.gif boost.css
+ dohtml -A pdf -r more
+ dohtml -r people
+ dohtml -r doc
+
+ find libs -type f -not -regex '^libs/[^/]*/build/.*' \
+ -and -not -regex '^libs/.*/test[^/]?/.*' \
+ -and -not -regex '^libs/.*/bench[^/]?/.*' \
+ -and -not -regex '^libs/[^/]*/tools/.*' \
+ -and -not -name \*.bat \
+ -and -not -name Jamfile\* \
+ -and -not -regex '^libs/[^/]*/src/.*' \
+ -and -not -iname makefile \
+ -and -not -name \*.mak \
+ -and -not -name .\* \
+ -and -not -name \*.dsw \
+ -and -not -name \*.dsp \
+ -exec \
+ install -D -m0644 \{\} ${D}/usr/share/doc/${P}/html/\{\} \;
+}
diff --git a/dev-libs/boost/files/digest-boost-1.31.0_alpha1 b/dev-libs/boost/files/digest-boost-1.31.0_alpha1
new file mode 100644
index 000000000000..2b55072a94a2
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.31.0_alpha1
@@ -0,0 +1 @@
+MD5 330544213967fb645ab80a8880d179be boost-2003d18.tar.bz2 5571333