summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/boost/boost-1.32.0-r1.ebuild')
-rw-r--r--dev-libs/boost/boost-1.32.0-r1.ebuild66
1 files changed, 61 insertions, 5 deletions
diff --git a/dev-libs/boost/boost-1.32.0-r1.ebuild b/dev-libs/boost/boost-1.32.0-r1.ebuild
index bb5a5e35c44a..590758233998 100644
--- a/dev-libs/boost/boost-1.32.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.32.0-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0-r1.ebuild,v 1.9 2005/03/18 06:56:46 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0-r1.ebuild,v 1.10 2005/03/20 07:14:55 morfic Exp $
# This ebuild was generated by Ebuilder v0.4.
-inherit python multilib
+inherit python multilib eutils
BOOST_PV1=${PV/./_}
BOOST_PV=${BOOST_PV1/./_}
@@ -37,6 +37,19 @@ pkg_setup() {
fi
BOOSTJAM=./tools/build/jam_src/bin.linux${arch}/bjam
+
+ einfo "MAKEOPTS are: ${MAKEOPTS}"
+
+ # we dont like what get_number_of_jobs does, so we borrow what counts to us,
+ # thanks H?kan Wessberg <nacka-gentoo@refug.org>, bug #13565
+
+ if [ "`egrep "^[[:space:]]*MAKEOPTS=" /etc/make.conf | wc -l`" -gt 0 ]; then
+ ADMINOPTS="`egrep "^[[:space:]]*MAKEOPTS=" /etc/make.conf | cut -d= -f2 | sed 's/\"//g'`"
+ ADMINPARAM="`echo ${ADMINOPTS} | gawk '{match($0, /-j *[0-9]*/, opt); print opt[0]}'`"
+ NUMJOBS="${ADMINPARAM}"
+ fi
+
+ einfo "number of jobs is: ${NUMJOBS}"
}
src_compile() {
@@ -46,6 +59,49 @@ src_compile() {
cd ${S}/tools/build/jam_src
./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
cd ${S}
+ # install build tools
+ cd tools/build
+ #do_whatever is too limiting here, need to move bunch of different stuff recursively
+ dodir /usr/share/${PN}
+ cp -a b* c* index.html v1/ v2/ ${D}/usr/share/${PN}
+ cd ${S}
+
+ if use icc ; then
+ export CPLUS_INCLUDE_PATH="/opt/intel/compiler80/include/c++"
+ export GXX_INCLUDE="/usr/include"
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sINTEL_PATH="/opt/intel/compiler80/" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sINTEL_PATH="/opt/intel/compiler80/" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ else
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ --prefix=${D}/usr \
+ --layout=system
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ --prefix=${D}/usr \
+ --layout=system
+
+ fi
+
}
@@ -60,7 +116,7 @@ src_install () {
if use icc ; then
export CPLUS_INCLUDE_PATH="/opt/intel/compiler80/include/c++"
export GXX_INCLUDE="/usr/include"
- ${BOOSTJAM} -sBOOST_ROOT=${S} \
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
-sPYTHON_VERSION=${PYVER} \
-sTOOLS=${BOOST_TOOLSET} \
@@ -69,7 +125,7 @@ src_install () {
--layout=system \
install || die "Install failed"
else
- ${BOOSTJAM} -sBOOST_ROOT=${S} \
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
-sPYTHON_VERSION=${PYVER} \
-sTOOLS=${BOOST_TOOLSET} \
@@ -79,7 +135,7 @@ src_install () {
fi
# Install documentation; seems to be mostly under ${S}/lib
- # install documentation
+ # install documentation
dodoc README
dohtml index.htm google_logo_40wht.gif c++boost.gif boost.css
dohtml -A pdf -r more