summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ocaml/ocaml-3.09.3-r1.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-3.09.3-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild b/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
index 6f49a8987015..59d9b762ec7f 100644
--- a/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild,v 1.22 2007/09/10 20:19:08 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild,v 1.23 2007/09/12 14:19:58 armin76 Exp $
inherit flag-o-matic eutils multilib pax-utils versionator toolchain-funcs
@@ -79,6 +79,9 @@ src_compile() {
strip-flags
replace-flags "-O?" -O2
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
use tk || myconf="${myconf} -no-tk"
use ncurses || myconf="${myconf} -no-curses"
use X || myconf="${myconf} -no-graph"