summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/syb/syb-0.3.6.1.ebuild')
-rw-r--r--dev-haskell/syb/syb-0.3.6.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-haskell/syb/syb-0.3.6.1.ebuild b/dev-haskell/syb/syb-0.3.6.1.ebuild
new file mode 100644
index 000000000000..e1a060892608
--- /dev/null
+++ b/dev-haskell/syb/syb-0.3.6.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/syb/syb-0.3.6.1.ebuild,v 1.1 2012/06/02 06:19:02 gienah Exp $
+
+EAPI=4
+
+# PDEPEND of ghc, so restrict depgraph
+CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Scrap Your Boilerplate"
+HOMEPAGE="http://www.cs.uu.nl/wiki/GenericProgramming/SYB"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}"