summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/muParser')
-rw-r--r--dev-cpp/muParser/ChangeLog11
-rw-r--r--dev-cpp/muParser/files/muParser-1.28-destdir.patch13
-rw-r--r--dev-cpp/muParser/files/muParser-1.28-gcc43.patch25
-rw-r--r--dev-cpp/muParser/files/muParser-1.30-build.patch28
-rw-r--r--dev-cpp/muParser/metadata.xml4
-rw-r--r--dev-cpp/muParser/muParser-2.2.3.ebuild50
6 files changed, 61 insertions, 70 deletions
diff --git a/dev-cpp/muParser/ChangeLog b/dev-cpp/muParser/ChangeLog
index ed86c518505f..fa26f15c1708 100644
--- a/dev-cpp/muParser/ChangeLog
+++ b/dev-cpp/muParser/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/muParser
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/ChangeLog,v 1.27 2012/08/14 16:59:44 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/ChangeLog,v 1.28 2013/06/17 16:16:00 bicatali Exp $
+
+*muParser-2.2.3 (17 Jun 2013)
+
+ 17 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> +muParser-2.2.3.ebuild,
+ -files/muParser-1.28-destdir.patch, -files/muParser-1.28-gcc43.patch,
+ -files/muParser-1.30-build.patch, metadata.xml:
+ Version bump and cleanup
14 Aug 2012; Justin Lecher <jlec@gentoo.org> -muParser-1.34.ebuild,
-muParser-2.1.0.ebuild, metadata.xml:
diff --git a/dev-cpp/muParser/files/muParser-1.28-destdir.patch b/dev-cpp/muParser/files/muParser-1.28-destdir.patch
deleted file mode 100644
index 3516c9791d54..000000000000
--- a/dev-cpp/muParser/files/muParser-1.28-destdir.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.in.orig 2007-08-01 21:54:43.001507250 +0100
-+++ Makefile.in 2007-08-01 21:55:40.649110000 +0100
-@@ -192,8 +192,8 @@
- all: $(__muParser_lib___depname) $(__muParser_dll___depname) $(__example1___depname)
-
- install: all $(__install_muParser_lib___depname) $(__install_muParser_lib_headers___depname) $(__install_muParser_dll___depname) $(__install_muParser_dll_headers___depname)
-- $(INSTALL_DIR) $(libdir)/pkgconfig
-- $(INSTALL_DATA) build/autoconf/muparser.pc $(libdir)/pkgconfig
-+ $(INSTALL_DIR) $(DESTDIR)$(libdir)/pkgconfig
-+ $(INSTALL_DATA) build/autoconf/muparser.pc $(DESTDIR)$(libdir)/pkgconfig
-
- uninstall: $(__uninstall_muParser_lib___depname) $(__uninstall_muParser_lib_headers___depname) $(__uninstall_muParser_dll___depname) $(__uninstall_muParser_dll_headers___depname)
-
diff --git a/dev-cpp/muParser/files/muParser-1.28-gcc43.patch b/dev-cpp/muParser/files/muParser-1.28-gcc43.patch
deleted file mode 100644
index 1fd972978ba3..000000000000
--- a/dev-cpp/muParser/files/muParser-1.28-gcc43.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- include/muParserTest.h.orig
-+++ include/muParserTest.h
-@@ -26,6 +26,7 @@
- #ifndef MU_PARSER_TEST_H
- #define MU_PARSER_TEST_H
-
-+#include <cstdlib>
- #include <string>
- #include <numeric> // for accumulate
- #include "muParser.h"
-@@ -87,12 +88,12 @@
-
- static value_type Rnd(value_type v)
- {
-- return (value_type)(1+(v*std::rand()/(RAND_MAX+1.0)));
-+ return (value_type)(1+(v*rand()/(RAND_MAX+1.0)));
- }
-
- static value_type RndWithString(const char_type*)
- {
-- return (value_type)( 1 + (1000.0f * std::rand() / (RAND_MAX + 1.0) ) );
-+ return (value_type)( 1 + (1000.0f * rand() / (RAND_MAX + 1.0) ) );
- }
-
- static value_type Ping()
diff --git a/dev-cpp/muParser/files/muParser-1.30-build.patch b/dev-cpp/muParser/files/muParser-1.30-build.patch
deleted file mode 100644
index 9ded9274fd46..000000000000
--- a/dev-cpp/muParser/files/muParser-1.30-build.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -Nur muparser.orig/configure muparser/configure
---- muparser.orig/configure 2008-06-09 22:51:39.000000000 +0100
-+++ muparser/configure 2009-03-09 16:12:02.335504093 +0000
-@@ -1927,10 +1927,6 @@
- NONENONEs,x,x, &&
- program_prefix=${target_alias}-
-
--CFLAGS=
--CXXFLAGS=
--CPPFLAGS=
--
- for ac_prog in gawk mawk nawk awk
- do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
-diff -Nur muparser.orig/Makefile.in muparser/Makefile.in
---- muparser.orig/Makefile.in 2008-06-09 22:51:39.000000000 +0100
-+++ muparser/Makefile.in 2009-03-09 16:07:55.871757201 +0000
-@@ -192,8 +192,8 @@
- all: $(__muParser_lib___depname) $(__muParser_dll___depname) $(__example1___depname)
-
- install: all $(__install_muParser_lib___depname) $(__install_muParser_lib_headers___depname) $(__install_muParser_dll___depname) $(__install_muParser_dll_headers___depname)
-- $(INSTALL_DIR) $(libdir)/pkgconfig
-- $(INSTALL_DATA) build/autoconf/muparser.pc $(libdir)/pkgconfig
-+ $(INSTALL_DIR) $(DESTDIR)$(libdir)/pkgconfig
-+ $(INSTALL_DATA) build/autoconf/muparser.pc $(DESTDIR)$(libdir)/pkgconfig
-
- uninstall: $(__uninstall_muParser_lib___depname) $(__uninstall_muParser_lib_headers___depname) $(__uninstall_muParser_dll___depname) $(__uninstall_muParser_dll_headers___depname)
-
diff --git a/dev-cpp/muParser/metadata.xml b/dev-cpp/muParser/metadata.xml
index 3e1c3341a76b..d0c4e16731ec 100644
--- a/dev-cpp/muParser/metadata.xml
+++ b/dev-cpp/muParser/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+<herd>sci-mathematics</herd>
+<longdescription lang="en">
muParser is a C++ library for mathematical expression parsing.
It is based on transforming an expression into a bytecode and
precalculating constant parts of it.
diff --git a/dev-cpp/muParser/muParser-2.2.3.ebuild b/dev-cpp/muParser/muParser-2.2.3.ebuild
new file mode 100644
index 000000000000..61a79bdd72c4
--- /dev/null
+++ b/dev-cpp/muParser/muParser-2.2.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/muParser-2.2.3.ebuild,v 1.1 2013/06/17 16:16:00 bicatali Exp $
+
+EAPI=5
+
+inherit eutils
+
+MYPN=${PN/P/p}
+MYP=${MYPN}_v${PV//./_}
+
+DESCRIPTION="Library for parsing mathematical expressions"
+HOMEPAGE="http://muparser.beltoforion.de/"
+SRC_URI="mirror://sourceforge/${MYPN}/${MYP}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.32-parallel-build.patch
+ sed -i \
+ -e 's:-O2::g' \
+ configure || die
+}
+
+src_configure() {
+ econf $(use_enable test samples)
+}
+
+src_test() {
+ cat > test.sh <<- EOFTEST
+ LD_LIBRARY_PATH=${S}/lib samples/example1/example1 <<- EOF
+ quit
+ EOF
+ EOFTEST
+ sh ./test.sh || die "test failed"
+}
+
+src_install() {
+ default
+ dodoc Changes.txt
+ use doc && dohtml -r docs/html/*
+}