summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/koffice/koffice-1.3.3.ebuild')
-rw-r--r--app-office/koffice/koffice-1.3.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-office/koffice/koffice-1.3.3.ebuild b/app-office/koffice/koffice-1.3.3.ebuild
new file mode 100644
index 000000000000..18e39aaefe68
--- /dev/null
+++ b/app-office/koffice/koffice-1.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.3.3.ebuild,v 1.1 2004/09/19 17:44:51 caleb Exp $
+
+inherit kde eutils
+
+# TODO : mysql support
+# other refs from configure: jasper, qt-docs, doxygen, libxml2, libxslt, freetype, fontconfig, qt being built with sql support (???)
+
+DESCRIPTION="A free, integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+SRC_URI="mirror://kde/stable/${P}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ppc64"
+
+IUSE=""
+SLOT="0"
+
+DEPEND=">=dev-lang/python-2.2.1
+ >=media-libs/libart_lgpl-2.3.9
+ >=media-gfx/imagemagick-5.4.5
+ >=app-text/wv2-0.1.8
+ dev-util/pkgconfig"
+need-kde 3.1
+
+src_compile() {
+ export LIBPYTHON="`python-config --libs`"
+ kde_src_compile
+}