summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tmux/tmux-1.2.ebuild')
-rw-r--r--app-misc/tmux/tmux-1.2.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/app-misc/tmux/tmux-1.2.ebuild b/app-misc/tmux/tmux-1.2.ebuild
deleted file mode 100644
index 82c050fc4199..000000000000
--- a/app-misc/tmux/tmux-1.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.2.ebuild,v 1.12 2011/01/07 14:06:29 jlec Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Terminal multiplexer"
-HOMEPAGE="http://tmux.sourceforge.net"
-SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="vim-syntax"
-
-DEPEND="
- <dev-libs/libevent-2
- sys-libs/ncurses"
-RDEPEND="${DEPEND}
- vim-syntax? ( || (
- app-editors/vim
- app-editors/gvim ) )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-locale.patch
-}
-
-src_compile() {
- # The configure script isn't created by GNU autotools.
- ./configure || die "configure failed"
- emake CC="$(tc-getCC)" || die "emake failed"
-}
-
-src_install() {
- dobin tmux || die "dobin failed"
-
- dodoc CHANGES FAQ NOTES TODO || die "dodoc failed"
- docinto examples
- dodoc examples/*.conf || die "dodoc examples failed"
-
- doman tmux.1 || die "doman failed"
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins examples/tmux.vim || die "doins syntax failed"
-
- insinto /usr/share/vim/vimfiles/ftdetect
- doins "${FILESDIR}"/tmux.vim || die "doins ftdetect failed"
- fi
-}