summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ne/ChangeLog6
-rw-r--r--app-editors/ne/files/ne-2.1-asneeded.patch13
-rw-r--r--app-editors/ne/ne-2.1.ebuild7
3 files changed, 22 insertions, 4 deletions
diff --git a/app-editors/ne/ChangeLog b/app-editors/ne/ChangeLog
index f36896180607..a93a49137c18 100644
--- a/app-editors/ne/ChangeLog
+++ b/app-editors/ne/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/ne
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ChangeLog,v 1.40 2010/05/31 11:56:35 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ChangeLog,v 1.41 2010/06/11 19:12:30 ssuominen Exp $
+
+ 11 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> ne-2.1.ebuild,
+ +files/ne-2.1-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #323595 by Diego E. Pettenò.
31 May 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> ne-2.0.3.ebuild:
x86 stable wrt bug #320911
diff --git a/app-editors/ne/files/ne-2.1-asneeded.patch b/app-editors/ne/files/ne-2.1-asneeded.patch
new file mode 100644
index 000000000000..8483d15b70f9
--- /dev/null
+++ b/app-editors/ne/files/ne-2.1-asneeded.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/323595
+
+--- src/makefile
++++ src/makefile
+@@ -104,7 +104,7 @@
+ LIBS=$(if $(NE_TERMCAP)$(NE_ANSI),,-lcurses)
+
+ ne: $(OBJS) $(if $(NE_TERMCAP)$(NE_ANSI),$(TERMCAPOBJS),)
+- $(CC) -lm $(OPTS) $(LDFLAGS) $^ $(LIBS) -o $(PROGRAM)
++ $(CC) $(OPTS) $(LDFLAGS) $^ -lm $(LIBS) -o $(PROGRAM)
+
+ clean:
+ rm -f *.o core
diff --git a/app-editors/ne/ne-2.1.ebuild b/app-editors/ne/ne-2.1.ebuild
index 1b944328362f..2c32c09132db 100644
--- a/app-editors/ne/ne-2.1.ebuild
+++ b/app-editors/ne/ne-2.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ne-2.1.ebuild,v 1.1 2010/05/21 16:53:11 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ne-2.1.ebuild,v 1.2 2010/06/11 19:12:30 ssuominen Exp $
EAPI="2"
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="the nice editor, easy to use for the beginner and powerful for the wizard"
HOMEPAGE="http://ne.dsi.unimi.it/"
@@ -20,7 +20,8 @@ DEPEND="${RDEPEND}
dev-lang/perl"
src_prepare() {
- sed -i -e s/-O3// "${S}"/src/makefile
+ sed -i -e 's/-O3//' src/makefile || die
+ epatch "${FILESDIR}"/${P}-asneeded.patch
}
src_compile() {