summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/dar')
-rw-r--r--app-backup/dar/ChangeLog7
-rw-r--r--app-backup/dar/Manifest2
-rw-r--r--app-backup/dar/dar-2.2.3.ebuild40
-rw-r--r--app-backup/dar/files/digest-dar-2.2.31
4 files changed, 49 insertions, 1 deletions
diff --git a/app-backup/dar/ChangeLog b/app-backup/dar/ChangeLog
index ee306ca2471f..ffc791cc79b5 100644
--- a/app-backup/dar/ChangeLog
+++ b/app-backup/dar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/dar
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.8 2005/09/03 13:11:31 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.9 2005/10/15 11:37:24 matsuu Exp $
+
+*dar-2.2.3 (15 Oct 2005)
+
+ 15 Oct 2005; MATSUU Takuto <matsuu@gentoo.org> +dar-2.2.3.ebuild:
+ Version bumped. Bug 108972.
03 Sep 2005; MATSUU Takuto <matsuu@gentoo.org> dar-2.2.2.ebuild:
filter-flags -fomit-frame-pointer. Bug 103741.
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index e72383a18d6b..20fe3017fc9d 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1,6 +1,8 @@
MD5 26d34c219873dbdfb17aa9e34f1dd059 dar-2.1.6.ebuild 1201
+MD5 0d74f3f8f0e65bb97da1cce8667d49af dar-2.2.3.ebuild 1145
MD5 2c2e07921cdc827bb7a64dd8cbcfd6f1 dar-2.2.2.ebuild 1141
MD5 db73e199369c3db3719ed3c12bd8c9f7 ChangeLog 4787
MD5 ae8f2b13b9e79b5760aa8c08f84bebe8 metadata.xml 468
MD5 386d1068d568e85b87309a279da188c4 files/digest-dar-2.1.6 61
MD5 a08cb65f15e68f63e8ad0d30f060d3d2 files/digest-dar-2.2.2 62
+MD5 215cc41777cf38cbd5e8973467199fee files/digest-dar-2.2.3 62
diff --git a/app-backup/dar/dar-2.2.3.ebuild b/app-backup/dar/dar-2.2.3.ebuild
new file mode 100644
index 000000000000..b0c990a0b0ce
--- /dev/null
+++ b/app-backup/dar/dar-2.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/dar-2.2.3.ebuild,v 1.1 2005/10/15 11:37:24 matsuu Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks (floppy,CDR(W),DVDR(W),zip,jazz etc.)"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="acl dar32 dar64 nls static"
+
+DEPEND=">=sys-libs/zlib-1.2.3
+ >=app-arch/bzip2-1.0.2
+ acl? ( sys-apps/attr )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf="--disable-upx"
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ use acl || myconf="${myconf} --disable-ea-support"
+ use dar32 && myconf="${myconf} --enable-mode=32"
+ use dar64 && myconf="${myconf} --enable-mode=64"
+ use nls || myconf="${myconf} --disable-nls"
+ use static || myconf="${myconf} --enable-static=no --disable-dar-static"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README THANKS TODO
+}
diff --git a/app-backup/dar/files/digest-dar-2.2.3 b/app-backup/dar/files/digest-dar-2.2.3
new file mode 100644
index 000000000000..64ce4d3c295d
--- /dev/null
+++ b/app-backup/dar/files/digest-dar-2.2.3
@@ -0,0 +1 @@
+MD5 dba3f87b87591b2972522e124bad3029 dar-2.2.3.tar.gz 1085437