summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unar/unar-1.1.ebuild')
-rw-r--r--app-arch/unar/unar-1.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-arch/unar/unar-1.1.ebuild b/app-arch/unar/unar-1.1.ebuild
new file mode 100644
index 000000000000..cc44074d9cdd
--- /dev/null
+++ b/app-arch/unar/unar-1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unar/unar-1.1.ebuild,v 1.1 2012/09/03 16:07:33 hanno Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Unpacker for various archiving formats, e.g. rar v3."
+HOMEPAGE="http://unarchiver.c3.cx/"
+SRC_URI="http://theunarchiver.googlecode.com/files/${PN}${PV}_src.zip"
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="gnustep-base/gnustep-base
+ >=gnustep-base/gnustep-make-2.6.0[native-exceptions]
+ dev-libs/icu"
+DEPEND="${RDEPEND}
+ sys-devel/gcc[objc]"
+
+S="${WORKDIR}/The Unarchiver/XADMaster"
+
+src_compile() {
+ emake -f Makefile.linux \
+ CC="$(tc-getCC)" \
+ OBJCC="$(tc-getCC)" \
+ C_OPTS="-std=gnu99 ${CFLAGS}" \
+ OBJC_OPTS="-std=gnu99 ${CFLAGS}" \
+ LD="$(tc-getCC)" \
+ LDFLAGS="-Wl,--whole-archive -fexceptions -fgnu-runtime \
+ ${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin unar lsar || die "dobin failed"
+ doman ../Extra/lsar.1 ../Extra/unar.1 || die "doman failed"
+}