summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/paxtest/paxtest-0.9.5-r1.ebuild')
-rw-r--r--app-admin/paxtest/paxtest-0.9.5-r1.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/app-admin/paxtest/paxtest-0.9.5-r1.ebuild b/app-admin/paxtest/paxtest-0.9.5-r1.ebuild
index b2d5a23fd226..39b50d6f52e4 100644
--- a/app-admin/paxtest/paxtest-0.9.5-r1.ebuild
+++ b/app-admin/paxtest/paxtest-0.9.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.5-r1.ebuild,v 1.8 2004/07/29 09:47:21 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.5-r1.ebuild,v 1.9 2004/07/29 19:09:08 lv Exp $
inherit eutils
@@ -24,12 +24,13 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/paxtest-0.9.5.1.diff
- cp Makefile{,.orig}
- cp Makefile{.Gentoo-hardened,}
# paxtest includes crt1S.S, which is great if you're on x86, but not so
- # much if you're not... lets use the system Scrt1.o
- use !x86 && cp ${ROOT}/usr/lib/Scrt1.o ${S}/crt1S.o
+ # much if you're not...
+ use !x86 && epatch ${FILESDIR}/paxtest-0.9.5-use-fPIE.patch
+
+ cp Makefile{,.orig}
+ cp Makefile{.Gentoo-hardened,}
}
src_compile() {
@@ -43,9 +44,3 @@ src_install() {
done
}
-pkg_postinst() {
- use !x86 && (
- ewarn "WARNING: support for non-x86 archs is currently a hack."
- ewarn "since you're not on x86, you may get \"Accessing a corrupted shared library\""
- ewarn "during the getmain2 and getheap2 tests." )
-}