summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/eflite/ChangeLog9
-rw-r--r--app-accessibility/eflite/files/eflite-0.3.8-daemon.patch59
-rw-r--r--app-accessibility/eflite/files/eflite-0.3.8-read_pipe.patch17
-rw-r--r--app-accessibility/eflite/files/eflite-0.3.8-shared_flite.patch41
4 files changed, 7 insertions, 119 deletions
diff --git a/app-accessibility/eflite/ChangeLog b/app-accessibility/eflite/ChangeLog
index b862f0f117a5..f4b9d7b4b2ab 100644
--- a/app-accessibility/eflite/ChangeLog
+++ b/app-accessibility/eflite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/eflite
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/eflite/ChangeLog,v 1.32 2009/12/29 00:17:11 williamh Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/eflite/ChangeLog,v 1.33 2010/12/29 19:06:24 williamh Exp $
+
+ 29 Dec 2010; William Hubbs <williamh@gentoo.org>
+ -files/eflite-0.3.8-daemon.patch, -files/eflite-0.3.8-read_pipe.patch,
+ -files/eflite-0.3.8-shared_flite.patch:
+ remove old patches
29 Dec 2009; William Hubbs <williamh@gentoo.org> -eflite-0.3.8-r2.ebuild:
removed old version
diff --git a/app-accessibility/eflite/files/eflite-0.3.8-daemon.patch b/app-accessibility/eflite/files/eflite-0.3.8-daemon.patch
deleted file mode 100644
index ceb9dbf8565b..000000000000
--- a/app-accessibility/eflite/files/eflite-0.3.8-daemon.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-diff -Naur eflite-0.3.8.orig/es.c eflite-0.3.8/es.c
---- eflite-0.3.8.orig/es.c 2004-02-20 15:58:35.000000000 -0800
-+++ eflite-0.3.8/es.c 2004-03-21 23:32:25.000000000 -0800
-@@ -760,9 +760,13 @@
- char *input = NULL;
- int more_opts = 1;
- int debug = 0;
-+ int daemon_only = 0;
-
-- while (more_opts) switch(getopt_long(argc, argv, "df:v", (struct option *)&longopts, NULL))
-+ while (more_opts) switch(getopt_long(argc, argv, "Ddf:v", (struct option *)&longopts, NULL))
- {
-+ case 'D':
-+ daemon_only = 1;
-+ break;
- case 'd':
- debug = 1;
- break;
-@@ -783,19 +787,32 @@
- sockname = lookup_string(NULL, "socketfile");
- if (!sockname) sockname = "/tmp/es.socket";
- local_fd = sockconnect(sockname);
-- if (local_fd != -1) passthrough(infile, local_fd);
-- if (!debug && (child = fork()))
-+
-+ if(daemon_only)
- {
-- usleep(200000);
-- local_fd = sockconnect(sockname);
-- if (local_fd == -1)
-+ if(local_fd != -1)
- {
-- es_log(1 | LOG_STDERR, "Daemon not accepting connections -- exiting\n");
-+ es_log(1 | LOG_STDERR, "Socket already exists. Exiting.\n");
- exit(1);
- }
-- passthrough(infile, local_fd);
-- exit(0);
- }
-+ else
-+ {
-+ if (local_fd != -1) passthrough(infile, local_fd);
-+ if (!debug && (child = fork()))
-+ {
-+ usleep(200000);
-+ local_fd = sockconnect(sockname);
-+ if (local_fd == -1)
-+ {
-+ es_log(1 | LOG_STDERR, "Daemon not accepting connections -- exiting\n");
-+ exit(1);
-+ }
-+ passthrough(infile, local_fd);
-+ exit(0);
-+ }
-+ }
-+
- punct_some = lookup_string(NULL, "punct_some");
- if (punct_some == NULL) punct_some = "@#$%^&_[]{}\\|";
- punct_all = lookup_string(NULL, "punct_all");
diff --git a/app-accessibility/eflite/files/eflite-0.3.8-read_pipe.patch b/app-accessibility/eflite/files/eflite-0.3.8-read_pipe.patch
deleted file mode 100644
index e5fd895bfbd3..000000000000
--- a/app-accessibility/eflite/files/eflite-0.3.8-read_pipe.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: es.c
-===================================================================
-RCS file: /cvsroot/eflite/eflite/es.c,v
-retrieving revision 1.20
-diff -r1.20 es.c
-714c714,722
-< if (size == -1) terror("read");
----
-> if (size == -1)
-> {
-> if (errno == EBADF)
-> {
-> /* this might really be an eof */
-> exit(0);
-> }
-> else terror("read");
-> }
diff --git a/app-accessibility/eflite/files/eflite-0.3.8-shared_flite.patch b/app-accessibility/eflite/files/eflite-0.3.8-shared_flite.patch
deleted file mode 100644
index a68f5757f62e..000000000000
--- a/app-accessibility/eflite/files/eflite-0.3.8-shared_flite.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -Naur eflite-0.3.8.orig/Makefile.in eflite-0.3.8/Makefile.in
---- eflite-0.3.8.orig/Makefile.in 2004-02-20 15:58:35.000000000 -0800
-+++ eflite-0.3.8/Makefile.in 2004-03-21 00:39:47.000000000 -0800
-@@ -27,10 +27,10 @@
- #CFLAGS+= -DDEBUG=2
-
- # For making releases
--FLITE_LIBS:=$(flite_dir)/lib/libflite_$(FL_VOX).a $(flite_dir)/lib/libflite_$(FL_LEX).a $(flite_dir)/lib/libflite_$(FL_LANG).a $(flite_dir)/lib/libflite.a
-+FLITE_LIBS:=-L$(flite_dir)/lib -lflite_$(FL_VOX) -lflite_$(FL_LEX) -lflite_$(FL_LANG) -lflite
-
--eflite: fs.o es.o soccon.o sockopen.o tone.o $(FLITE_LIBS)
-- $(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS)
-+eflite: fs.o es.o soccon.o sockopen.o tone.o
-+ $(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS) $(FLITE_LIBS)
-
- fs.o: fs.c
- $(CC) $(CFLAGS) -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(subst cmu_us_kal16,cmu_us_kal,$(FL_VOX)) -DSTANDALONE -DEFLITE -c -o $@ $<
-diff -Naur eflite-0.3.8.orig/configure.in eflite-0.3.8/configure.in
---- eflite-0.3.8.orig/configure.in 2004-02-20 15:58:35.000000000 -0800
-+++ eflite-0.3.8/configure.in 2004-03-21 00:37:08.000000000 -0800
-@@ -29,6 +29,20 @@
- flite_dir=/usr/src/flite-1.1-release;
- elif test -f /usr/local/src/flite-1.1-release/lib/libflite.a; then
- flite_dir=/usr/local/src/flite-1.1-release;
-+ elif test -f /usr/local/lib/libflite.so; then
-+ flite_dir=/usr/local
-+ elif test -f /usr/lib/libflite.so; then
-+ flite_dir=/usr
-+ elif test -f /opt/flite/lib/libflite.so; then
-+ flite_dir=/opt
-+ elif test -f $HOME/flite-1.2-release/lib/libflite.so; then
-+ flite_dir=$HOME/flite-1.2-release
-+ elif test -f $HOME/flite-1.1-release/lib/libflite.so; then
-+ flite_dir=$HOME/flite-1.1-release
-+ elif test -f /usr/src/flite-1.1-release/lib/libflite.so; then
-+ flite_dir=/usr/src/flite-1.1-release;
-+ elif test -f /usr/local/src/flite-1.1-release/lib/libflite.so; then
-+ flite_dir=/usr/local/src/flite-1.1-release;
- else
- AC_MSG_ERROR(Cannot locate libflite.a. Please specify flite_dir explicitly (see INSTALL). If you do not have FLite headers and libraries available, then compile FLite and re-run configure.)
- fi