summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/keepassx/ChangeLog6
-rw-r--r--app-admin/keepassx/keepassx-0.3.0a-r20.ebuild14
-rw-r--r--app-admin/keepassx/keepassx-0.3.0a.ebuild19
3 files changed, 24 insertions, 15 deletions
diff --git a/app-admin/keepassx/ChangeLog b/app-admin/keepassx/ChangeLog
index eb93bfa4b62f..f3a1babc1ee7 100644
--- a/app-admin/keepassx/ChangeLog
+++ b/app-admin/keepassx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/keepassx
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/ChangeLog,v 1.21 2008/03/04 18:41:21 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/ChangeLog,v 1.22 2008/03/11 12:53:52 opfer Exp $
+
+ 11 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
+ keepassx-0.3.0a.ebuild, keepassx-0.3.0a-r20.ebuild:
+ revamp ebuild, proposed by jokey in bug 212984
*keepassx-0.3.0a-r20 (04 Mar 2008)
*keepassx-0.3.0a (04 Mar 2008)
diff --git a/app-admin/keepassx/keepassx-0.3.0a-r20.ebuild b/app-admin/keepassx/keepassx-0.3.0a-r20.ebuild
index 0300e591f20d..5f2967dabfc3 100644
--- a/app-admin/keepassx/keepassx-0.3.0a-r20.ebuild
+++ b/app-admin/keepassx/keepassx-0.3.0a-r20.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.3.0a-r20.ebuild,v 1.1 2008/03/04 18:41:21 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.3.0a-r20.ebuild,v 1.2 2008/03/11 12:53:52 opfer Exp $
-inherit eutils
+EAPI=1
+
+inherit eutils qt4
DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions"
HOMEPAGE="http://keepassx.sourceforge.net/"
@@ -12,18 +14,18 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND="( >=x11-libs/qt-4.4.0_rc1
+DEPEND="( >=x11-libs/qt-4.4.0_rc1:4
x11-libs/qt-qt3support )"
RDEPEND="${DEPEND}"
S="${WORKDIR}/KeePassX-${PV}"
src_compile() {
cd "${S}/src"
- lrelease src.pro || die "lrelease failed"
+ lrelease src.pro || die
mv "${S}"/src/translations/*.qm "${S}"/share/keepassx/i18n
cd "${S}"
- /usr/bin/qmake || die "qmake failed"
- emake || die "emake failed"
+ eqmake keepass.pro PREFIX="${D}/usr" ${myconf} || die
+ emake || die
}
src_install(){
diff --git a/app-admin/keepassx/keepassx-0.3.0a.ebuild b/app-admin/keepassx/keepassx-0.3.0a.ebuild
index 0cc9c5149416..ad43923291dc 100644
--- a/app-admin/keepassx/keepassx-0.3.0a.ebuild
+++ b/app-admin/keepassx/keepassx-0.3.0a.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.3.0a.ebuild,v 1.1 2008/03/04 18:41:21 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.3.0a.ebuild,v 1.2 2008/03/11 12:53:51 opfer Exp $
-inherit eutils
+EAPI=1
+
+inherit eutils qt4
DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions"
HOMEPAGE="http://keepassx.sourceforge.net/"
@@ -12,27 +14,28 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug"
-DEPEND=">=x11-libs/qt-4.1"
+DEPEND=">=x11-libs/qt-4.1:4"
RDEPEND="${DEPEND}"
+
S="${WORKDIR}/KeePassX-${PV}"
pkg_setup() {
if ! built_with_use --missing true x11-libs/qt qt3support png; then
eerror
- eerror "You need to rebuild x11-libs/qt with USE=qt3support enabled"
+ eerror "You need to rebuild x11-libs/qt with USE=qt3support and png enabled"
eerror
- die "please rebuild x11-libs/qt with USE=qt3support"
+ die "please rebuild x11-libs/qt with USE=\"qt3support png\""
fi
}
src_compile() {
cd "${S}/src"
- lrelease src.pro || die "lrelease failed"
+ lrelease src.pro || die
mv "${S}"/src/translations/*.qm "${S}"/share/keepassx/i18n
cd "${S}"
use debug || myconf="DEBUG=1"
- /usr/bin/qmake PREFIX="${D}/usr" ${myconf} || die "qmake failed"
- emake || die "emake failed"
+ eqmake keepass.pro PREFIX="${D}/usr" ${myconf}|| die
+ emake || die
}
src_install(){