summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/hal/ChangeLog5
-rw-r--r--sys-apps/hal/hal-0.5.9.ebuild6
2 files changed, 9 insertions, 2 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index c5407fdba710..1a578154539e 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.164 2007/04/13 01:26:05 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.165 2007/04/13 14:12:09 cardoe Exp $
+
+ 13 Apr 2007; Doug Goldstein <cardoe@gentoo.org> hal-0.5.9.ebuild:
+ We don't support pciutils pci.ids files gzipped
13 Apr 2007; Doug Goldstein <cardoe@gentoo.org>
+files/0.5.9/08_contains_not_fdi_directive.patch,
diff --git a/sys-apps/hal/hal-0.5.9.ebuild b/sys-apps/hal/hal-0.5.9.ebuild
index 6dcda1417313..4668cf1d388f 100644
--- a/sys-apps/hal/hal-0.5.9.ebuild
+++ b/sys-apps/hal/hal-0.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.9.ebuild,v 1.18 2007/04/12 16:43:50 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.9.ebuild,v 1.19 2007/04/13 14:12:09 cardoe Exp $
inherit eutils linux-info autotools flag-o-matic
@@ -76,6 +76,10 @@ function notify_inotify() {
}
pkg_setup() {
+ if built_with_use --missing false sys-apps/pciutils zlib ; then
+ die "You MUST build pciutils without the zlib USE flag"
+ fi
+
if use kernel_linux; then
kernel_is ge 2 6 17 || ewarn "HAL requires a kernel version 2.6.17 or newer"