summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-accessibility/pidgin-festival/ChangeLog8
-rw-r--r--app-accessibility/pidgin-festival/pidgin-festival-2.2.ebuild17
2 files changed, 20 insertions, 5 deletions
diff --git a/app-accessibility/pidgin-festival/ChangeLog b/app-accessibility/pidgin-festival/ChangeLog
index 6725f92ed33a..44b37b3a2a6a 100644
--- a/app-accessibility/pidgin-festival/ChangeLog
+++ b/app-accessibility/pidgin-festival/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/pidgin-festival
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/pidgin-festival/ChangeLog,v 1.4 2007/11/09 22:04:52 nixnut Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/pidgin-festival/ChangeLog,v 1.5 2008/01/09 15:32:12 tester Exp $
+
+ 09 Jan 2008; Olivier Crête <tester@gentoo.org>
+ pidgin-festival-2.2.ebuild:
+ Add required dependencies on pkg-config, pidgin and gtk
09 Nov 2007; nixnut <nixnut@gentoo.org> pidgin-festival-2.2.ebuild:
Added ~ppc wrt bug 197103
diff --git a/app-accessibility/pidgin-festival/pidgin-festival-2.2.ebuild b/app-accessibility/pidgin-festival/pidgin-festival-2.2.ebuild
index 51ae41251c13..418a81f1a76a 100644
--- a/app-accessibility/pidgin-festival/pidgin-festival-2.2.ebuild
+++ b/app-accessibility/pidgin-festival/pidgin-festival-2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/pidgin-festival/pidgin-festival-2.2.ebuild,v 1.4 2007/11/09 22:04:52 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/pidgin-festival/pidgin-festival-2.2.ebuild,v 1.5 2008/01/09 15:32:12 tester Exp $
DESCRIPTION="A plugin for pidgin which enables text-to-speech output of conversations using festival."
HOMEPAGE="http://pidgin.festival.sourceforge.net"
@@ -14,7 +14,18 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""
RDEPEND="app-accessibility/festival
- net-im/pidgin"
+ net-im/pidgin
+ >=x11-libs/gtk+-2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if ! built_with_use net-im/pidgin gtk; then
+ eerror "You need to compile net-im/pidgin with USE=gtk"
+ die "Missing gtk USE flag on net-im/pidgin"
+ fi
+}
src_install() {
make DESTDIR="${D}" install || die