summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/zbar/ChangeLog9
-rw-r--r--media-gfx/zbar/zbar-0.10-r5.ebuild68
2 files changed, 75 insertions, 2 deletions
diff --git a/media-gfx/zbar/ChangeLog b/media-gfx/zbar/ChangeLog
index 77023dafb80c..8585b3b55953 100644
--- a/media-gfx/zbar/ChangeLog
+++ b/media-gfx/zbar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/zbar
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/zbar/ChangeLog,v 1.14 2013/11/27 23:11:56 vapier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/zbar/ChangeLog,v 1.15 2014/11/30 13:09:57 mgorny Exp $
+
+*zbar-0.10-r5 (30 Nov 2014)
+
+ 30 Nov 2014; Michał Górny <mgorny@gentoo.org> +zbar-0.10-r5.ebuild:
+ Convert to python-single-r1.
*zbar-0.10-r4 (27 Nov 2013)
diff --git a/media-gfx/zbar/zbar-0.10-r5.ebuild b/media-gfx/zbar/zbar-0.10-r5.ebuild
new file mode 100644
index 000000000000..54df71196ee9
--- /dev/null
+++ b/media-gfx/zbar/zbar-0.10-r5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/zbar/zbar-0.10-r5.ebuild,v 1.1 2014/11/30 13:09:57 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils flag-o-matic python-single-r1
+
+DESCRIPTION="Library and tools for reading barcodes from images or video"
+HOMEPAGE="http://zbar.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zbar/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gtk imagemagick jpeg python qt4 static-libs +threads v4l X xv"
+
+RDEPEND="gtk? ( dev-libs/glib:2 x11-libs/gtk+:2 )
+ imagemagick? (
+ || ( media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick] ) )
+ jpeg? ( virtual/jpeg )
+ python? ( ${PYTHON_DEPS}
+ gtk? ( >=dev-python/pygtk-2[${PYTHON_USEDEP}] ) )
+ qt4? ( dev-qt/qtcore:4 dev-qt/qtgui:4 )
+ X? ( x11-libs/libXext
+ xv? ( x11-libs/libXv ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-v4l1-check.patch
+ epatch "${FILESDIR}"/${P}-errors.patch
+ epatch "${FILESDIR}"/${P}-python-crash.patch
+
+ python_fix_shebang examples/upcrpc.py test/*.py
+
+ sed -i -e '/AM_INIT_AUTOMAKE/s:-Werror ::' configure.ac || die #423581
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -DNDEBUG
+ econf \
+ $(use_with jpeg) \
+ $(use_with gtk) \
+ $(use_with imagemagick) \
+ $(use_with python) \
+ $(use_with qt4 qt) \
+ $(use_enable static-libs static) \
+ $(use_enable threads pthread) \
+ $(use_with X x) \
+ $(use_with xv xv) \
+ $(use_enable v4l video)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc HACKING NEWS README TODO
+ rm -r "${ED}"/usr/share/doc/${PN}
+ prune_libtool_files --all
+}