summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/sptk/ChangeLog7
-rw-r--r--dev-cpp/sptk/sptk-2.3.28.ebuild6
-rw-r--r--dev-cpp/sptk/sptk-3.5.7.13.ebuild6
-rw-r--r--dev-cpp/sptk/sptk-3.5.8.4.ebuild6
-rw-r--r--dev-cpp/sptk/sptk-3.5.8.6.ebuild6
-rw-r--r--dev-cpp/sptk/sptk-3.5.8.ebuild6
6 files changed, 26 insertions, 11 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index d553081f48ed..189e7636648e 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.43 2008/11/11 09:46:23 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.44 2008/11/15 12:09:14 coldwind Exp $
+
+ 15 Nov 2008; Santiago M. Mola <coldwind@gentoo.org> sptk-2.3.28.ebuild,
+ sptk-3.5.7.13.ebuild, sptk-3.5.8.ebuild, sptk-3.5.8.4.ebuild,
+ sptk-3.5.8.6.ebuild:
+ Restrict fltk dependency to SLOT 1.1 (bug #246445).
11 Nov 2008; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
-sptk-3.5.7.10.ebuild, sptk-3.5.7.13.ebuild:
diff --git a/dev-cpp/sptk/sptk-2.3.28.ebuild b/dev-cpp/sptk/sptk-2.3.28.ebuild
index 6db8be93c9fa..3d645000746f 100644
--- a/dev-cpp/sptk/sptk-2.3.28.ebuild
+++ b/dev-cpp/sptk/sptk-2.3.28.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-2.3.28.ebuild,v 1.5 2008/02/26 13:09:58 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-2.3.28.ebuild,v 1.6 2008/11/15 12:09:14 coldwind Exp $
+
+EAPI=1
IUSE="fltk odbc"
@@ -12,7 +14,7 @@ SLOT="2"
LICENSE="|| ( FLTK GPL-2 )"
KEYWORDS="x86 ~sparc ~mips ~amd64 ~ppc"
-DEPEND="fltk? ( x11-libs/fltk )
+DEPEND="fltk? ( x11-libs/fltk:1.1 )
odbc? ( >=dev-db/unixODBC-2.2.6 )"
src_compile() {
diff --git a/dev-cpp/sptk/sptk-3.5.7.13.ebuild b/dev-cpp/sptk/sptk-3.5.7.13.ebuild
index 6c4135057049..b1da32e8546e 100644
--- a/dev-cpp/sptk/sptk-3.5.7.13.ebuild
+++ b/dev-cpp/sptk/sptk-3.5.7.13.ebuild
@@ -1,6 +1,8 @@
# Copyright 2006-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.7.13.ebuild,v 1.4 2008/11/11 09:46:23 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.7.13.ebuild,v 1.5 2008/11/15 12:09:14 coldwind Exp $
+
+EAPI=1
inherit eutils flag-o-matic autotools multilib
@@ -14,7 +16,7 @@ SLOT="3"
LICENSE="|| ( BSD )"
KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc x86"
-RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6 )
+RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6:1.1 )
odbc? ( >=dev-db/unixODBC-2.2.6 )
sqlite3? ( >=dev-db/sqlite-3 )
aspell? ( >=app-text/aspell-0.50 )"
diff --git a/dev-cpp/sptk/sptk-3.5.8.4.ebuild b/dev-cpp/sptk/sptk-3.5.8.4.ebuild
index 62b8ef66d71f..f429d11fc1f4 100644
--- a/dev-cpp/sptk/sptk-3.5.8.4.ebuild
+++ b/dev-cpp/sptk/sptk-3.5.8.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 2006-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.4.ebuild,v 1.1 2008/11/05 09:55:57 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.4.ebuild,v 1.2 2008/11/15 12:09:14 coldwind Exp $
+
+EAPI=1
inherit eutils flag-o-matic autotools multilib
@@ -14,7 +16,7 @@ SLOT="3"
LICENSE="|| ( BSD )"
KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
-RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6 )
+RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6:1.1 )
odbc? ( >=dev-db/unixODBC-2.2.6 )
sqlite3? ( >=dev-db/sqlite-3 )
postgres? ( >=virtual/postgresql-base-8.0 )
diff --git a/dev-cpp/sptk/sptk-3.5.8.6.ebuild b/dev-cpp/sptk/sptk-3.5.8.6.ebuild
index f7b121a71571..e001cfa0e636 100644
--- a/dev-cpp/sptk/sptk-3.5.8.6.ebuild
+++ b/dev-cpp/sptk/sptk-3.5.8.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 2006-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.6.ebuild,v 1.1 2008/11/11 09:20:30 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.6.ebuild,v 1.2 2008/11/15 12:09:14 coldwind Exp $
+
+EAPI=1
inherit eutils flag-o-matic autotools multilib
@@ -14,7 +16,7 @@ SLOT="3"
LICENSE="|| ( BSD )"
KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
-RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6 )
+RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6:1.1 )
odbc? ( >=dev-db/unixODBC-2.2.6 )
sqlite3? ( >=dev-db/sqlite-3 )
postgres? ( >=virtual/postgresql-base-8.0 )
diff --git a/dev-cpp/sptk/sptk-3.5.8.ebuild b/dev-cpp/sptk/sptk-3.5.8.ebuild
index c1dc9e8ae364..d0c6b5e8bf24 100644
--- a/dev-cpp/sptk/sptk-3.5.8.ebuild
+++ b/dev-cpp/sptk/sptk-3.5.8.ebuild
@@ -1,6 +1,8 @@
# Copyright 2006-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.ebuild,v 1.3 2008/10/09 14:44:58 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.ebuild,v 1.4 2008/11/15 12:09:14 coldwind Exp $
+
+EAPI=1
inherit eutils flag-o-matic autotools multilib
@@ -14,7 +16,7 @@ SLOT="3"
LICENSE="|| ( BSD )"
KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
-RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6 )
+RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6:1.1 )
odbc? ( >=dev-db/unixODBC-2.2.6 )
sqlite3? ( >=dev-db/sqlite-3 )
postgres? ( >=virtual/postgresql-base-8.0 )