summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-print/magicfilter/files/StylusColor-777-Photo-filter157
-rw-r--r--net-print/magicfilter/files/StylusColor-777-Picture-filter157
-rw-r--r--net-print/magicfilter/files/StylusColor-777-Text-filter157
-rw-r--r--net-print/magicfilter/files/digest-magicfilter-1.21
-rw-r--r--net-print/magicfilter/files/escp-text-helper19
-rw-r--r--net-print/magicfilter/magicfilter-1.2.ebuild53
6 files changed, 0 insertions, 544 deletions
diff --git a/net-print/magicfilter/files/StylusColor-777-Photo-filter b/net-print/magicfilter/files/StylusColor-777-Photo-filter
deleted file mode 100644
index cdaa30c87625..000000000000
--- a/net-print/magicfilter/files/StylusColor-777-Photo-filter
+++ /dev/null
@@ -1,157 +0,0 @@
-#!/usr/sbin/magicfilter
-# vim:set nowrap:
-#
-# Magic filter setup file for the EPSON Stylus Color 777 printer operating
-# at 360 dpi, originally based on StylusColor-800@360dpi-filter.
-#
-# 8 July 2001 agriffis
-
-# All documents sent to the printer should be prefixed by the magic
-# command and the reset code. The 'magic command' takes the printer
-# out of the Epson packet mode communication protocol (whatever that
-# is) and enables normal data transfer. The 'reset code' discards any
-# output, ejects the existing page, and returns all settings to their
-# default.
-0 \000\000\000\033\001@EJL\ 1284.4\n@EJL\ \ \ \ \ \n\033@ cat
-
-# Native printer control codes start with <ESC>, but if this wasn't
-# recognized by the magic above, then the reset code should be
-# prefixed. Then we pass the document to the printer, cross our
-# fingers and hope for the best.
-#
-# Note that we add a ff/reset on the end just for good measure...
-0 \033 cat \000\000\000\033\001@EJL\ 1284.4\n@EJL\ \ \ \ \ \n\033@ \014\033@
-
-# PostScript, use ghostscript with the gimp-print driver. This is
-# done as a pipe (instead of a filter, which would go directly to the
-# printer) so that magicfilter can then decide whether or not a reset
-# sequence should be prefixed to the output.
-0 %! pipe /usr/bin/gs -q @stc777-photo.upp -sOutputFile=- - -c quit
-0 \004%! pipe /usr/bin/gs -q @stc777-photo.upp -sOutputFile=- - -c quit
-
-# PDF
-0 %PDF fpipe /usr/bin/pdftops $FILE -
-
-# TeX DVI
-0 \367\002 fpipe /usr/bin/dvips -D 360 -R -q -f
-
-# compress'd data
-0 \037\235 pipe /bin/gzip -cdq
-
-# packed, gzipped, frozen and SCO LZH data
-0 \037\036 pipe /bin/gzip -cdq
-0 \037\213 pipe /bin/gzip -cdq
-0 \037\236 pipe /bin/gzip -cdq
-0 \037\240 pipe /bin/gzip -cdq
-
-0 BZh pipe /usr/bin/bzip2 -cdq
-
-# troff documents
-0 .\?\?\040 fpipe `/usr/bin/grog -Tps $FILE`
-0 .\\\" fpipe `/usr/bin/grog -Tps $FILE`
-0 '\\\" fpipe `/usr/bin/grog -Tps $FILE`
-0 '.\\\" fpipe `/usr/bin/grog -Tps $FILE`
-0 \\\" fpipe `/usr/bin/grog -Tps $FILE`
-
-# ditroff
-0 "x T ps" pipe /usr/bin/grops
-0 "x T dvi" pipe /usr/bin/grodvi
-0 "x T ascii" pipe /usr/bin/grotty
-0 "x T latin1" pipe /usr/bin/grotty
-0 "x T lj4" reject Cannot print LaserJet 4 ditroff files.
-
-# Portable bit-, grey- and pixmaps
-0 P1\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P2\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P3\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P4\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P5\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P6\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-
-# PNG - Portable network graphics
-0 \x89PNG pipe /usr/bin/pngtopnm
-
-# HP Printer Control Language (PCL) -- assume start with reset code
-0 \033E\033 reject Cannot print PCL files on this printer.
-
-# HP Printer Job Language (PJL)
-0 \033%-12345X reject Cannot print PJL files on this printer.
-0 "@PJL " reject Cannot print PJL files on this printer.
-0 @PJL\t reject Cannot print PJL files on this printer.
-0 @PJL\r reject Cannot print PJL files on this printer.
-0 @PJL\n reject Cannot print PJL files on this printer.
-
-# GIF files
-0 GIF87a pipe /usr/bin/giftopnm 2>/dev/null
-0 GIF89a pipe /usr/bin/giftopnm 2>/dev/null
-
-# JFIF (JPEG) files
-0 \377\330\377\340\?\?JFIF\0 pipe /usr/bin/djpeg -pnm
-# Bug 40599
-0 \377\330\377\341\?\?Exif\0 pipe /usr/bin/djpeg -pnm
-
-# TIFF files (the last two bytes of the "magic" is really a version number;
-# but the magic is really lame and as far as I have understood the version
-# number has never changed and never will, so we include it.)
-0 MM\0\x2a fpipe /usr/bin/tiff2ps -a $FILE
-0 II\x2a\0 fpipe /usr/bin/tiff2ps -a $FILE
-
-# BMP files (even lousier magic -- Microsoft strikes again!)
-0 BM\?\?\?\?\?\?\?\?\?\?\?\?\x0c pipe \
- /usr/bin/bmptoppm 2>/dev/null
-0 BM\?\?\?\?\?\?\?\?\?\?\?\?\x40 pipe \
- /usr/bin/bmptoppm 2>/dev/null
-0 BM\?\?\?\?\?\?\?\?\?\?\?\?\x28 pipe \
- /usr/bin/bmptoppm 2>/dev/null
-
-# Garbage delivered from Windows via Samba
-# (donated by Andree Leidenfrost <leidenfrost@dkrz.de>)
-# 300 \033\052\157 cat
-# later changed to
-# (Bug report #22866: magicfilter: Incorrect magic for Win95/Samba print jobs)
-0 \000\000\000\000\000 cat
-
-# Sun rasterfiles
-0 \x59\xa6\x6a\x95 pipe /usr/bin/rasttopnm 2>/dev/null
-
-# SGI Imagelib (IRIS RGB) files
-0 \x1\xda pipe /usr/bin/sgitopnm 2>/dev/null
-0 \xda\x1 pipe /usr/bin/sgitopnm 2>/dev/null
-
-# FIG files; reported by Steven P. Hill <sph@uscbu.ih.att.com>
-0 \043FIG pipe /usr/bin/fig2dev -Lps -P -l dummy
-
-#
-# Standard rejects... things we don't want to print
-#
-
-# Various archive formats
-257 ustar\0 reject Attempted to print a tar file.
-257 "ustar \0" reject Attempted to print a tar file.
-0 07070 reject Attempted to print a cpio file.
-0 PK\3\4 reject Attempted to print a zip file.
-20 \xdc\xa7\xc7\xfd reject Attempted to print a zoo file.
-
-# Binaries (Linux): reject with email message
-0 \013\1d\0 reject Attempted to print a compiled binary.
-0 \100\1d\0 reject Attempted to print a compiled binary.
-0 \007\1d\0 reject Attempted to print a compiled binary.
-0 \314\0d\0 reject Attempted to print a compiled binary.
-0 \177ELF reject Attempted to print an ELF object.
-0 \007\001\0 reject Attempted to print an object file.
-216 \021\001\0\0 reject Attempted to print a core dump file.
-0 !<arch> reject Attempted to print an archive.
-0 =<ar> reject Attempted to print an archive.
-
-# Don't confuse this one with troff!
-0 .snd reject Attempted to print Sun/NeXT audio data.
-
-# wacko troff magic
-0 ''' fpipe `/usr/bin/grog -Tps $FILE`
-
-# Default entry for normal (text) files. This must be the last entry!
-# =====================================================================
-# Please adjust recode's codepage conversion manually according to your
-# local needs. We apologize for the inconveniences...
-#
-default filter /etc/magicfilter/escp-text-helper
diff --git a/net-print/magicfilter/files/StylusColor-777-Picture-filter b/net-print/magicfilter/files/StylusColor-777-Picture-filter
deleted file mode 100644
index 88fa71c0c753..000000000000
--- a/net-print/magicfilter/files/StylusColor-777-Picture-filter
+++ /dev/null
@@ -1,157 +0,0 @@
-#!/usr/sbin/magicfilter
-# vim:set nowrap:
-#
-# Magic filter setup file for the EPSON Stylus Color 777 printer operating
-# at 360 dpi, originally based on StylusColor-800@360dpi-filter.
-#
-# 8 July 2001 agriffis
-
-# All documents sent to the printer should be prefixed by the magic
-# command and the reset code. The 'magic command' takes the printer
-# out of the Epson packet mode communication protocol (whatever that
-# is) and enables normal data transfer. The 'reset code' discards any
-# output, ejects the existing page, and returns all settings to their
-# default.
-0 \000\000\000\033\001@EJL\ 1284.4\n@EJL\ \ \ \ \ \n\033@ cat
-
-# Native printer control codes start with <ESC>, but if this wasn't
-# recognized by the magic above, then the reset code should be
-# prefixed. Then we pass the document to the printer, cross our
-# fingers and hope for the best.
-#
-# Note that we add a ff/reset on the end just for good measure...
-0 \033 cat \000\000\000\033\001@EJL\ 1284.4\n@EJL\ \ \ \ \ \n\033@ \014\033@
-
-# PostScript, use ghostscript with the gimp-print driver. This is
-# done as a pipe (instead of a filter, which would go directly to the
-# printer) so that magicfilter can then decide whether or not a reset
-# sequence should be prefixed to the output.
-0 %! pipe /usr/bin/gs -q @stc777-picture.upp -sOutputFile=- - -c quit
-0 \004%! pipe /usr/bin/gs -q @stc777-picture.upp -sOutputFile=- - -c quit
-
-# PDF
-0 %PDF fpipe /usr/bin/pdftops $FILE -
-
-# TeX DVI
-0 \367\002 fpipe /usr/bin/dvips -D 360 -R -q -f
-
-# compress'd data
-0 \037\235 pipe /bin/gzip -cdq
-
-# packed, gzipped, frozen and SCO LZH data
-0 \037\036 pipe /bin/gzip -cdq
-0 \037\213 pipe /bin/gzip -cdq
-0 \037\236 pipe /bin/gzip -cdq
-0 \037\240 pipe /bin/gzip -cdq
-
-0 BZh pipe /usr/bin/bzip2 -cdq
-
-# troff documents
-0 .\?\?\040 fpipe `/usr/bin/grog -Tps $FILE`
-0 .\\\" fpipe `/usr/bin/grog -Tps $FILE`
-0 '\\\" fpipe `/usr/bin/grog -Tps $FILE`
-0 '.\\\" fpipe `/usr/bin/grog -Tps $FILE`
-0 \\\" fpipe `/usr/bin/grog -Tps $FILE`
-
-# ditroff
-0 "x T ps" pipe /usr/bin/grops
-0 "x T dvi" pipe /usr/bin/grodvi
-0 "x T ascii" pipe /usr/bin/grotty
-0 "x T latin1" pipe /usr/bin/grotty
-0 "x T lj4" reject Cannot print LaserJet 4 ditroff files.
-
-# Portable bit-, grey- and pixmaps
-0 P1\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P2\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P3\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P4\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P5\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P6\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-
-# PNG - Portable network graphics
-0 \x89PNG pipe /usr/bin/pngtopnm
-
-# HP Printer Control Language (PCL) -- assume start with reset code
-0 \033E\033 reject Cannot print PCL files on this printer.
-
-# HP Printer Job Language (PJL)
-0 \033%-12345X reject Cannot print PJL files on this printer.
-0 "@PJL " reject Cannot print PJL files on this printer.
-0 @PJL\t reject Cannot print PJL files on this printer.
-0 @PJL\r reject Cannot print PJL files on this printer.
-0 @PJL\n reject Cannot print PJL files on this printer.
-
-# GIF files
-0 GIF87a pipe /usr/bin/giftopnm 2>/dev/null
-0 GIF89a pipe /usr/bin/giftopnm 2>/dev/null
-
-# JFIF (JPEG) files
-0 \377\330\377\340\?\?JFIF\0 pipe /usr/bin/djpeg -pnm
-# Bug 40599
-0 \377\330\377\341\?\?Exif\0 pipe /usr/bin/djpeg -pnm
-
-# TIFF files (the last two bytes of the "magic" is really a version number;
-# but the magic is really lame and as far as I have understood the version
-# number has never changed and never will, so we include it.)
-0 MM\0\x2a fpipe /usr/bin/tiff2ps -a $FILE
-0 II\x2a\0 fpipe /usr/bin/tiff2ps -a $FILE
-
-# BMP files (even lousier magic -- Microsoft strikes again!)
-0 BM\?\?\?\?\?\?\?\?\?\?\?\?\x0c pipe \
- /usr/bin/bmptoppm 2>/dev/null
-0 BM\?\?\?\?\?\?\?\?\?\?\?\?\x40 pipe \
- /usr/bin/bmptoppm 2>/dev/null
-0 BM\?\?\?\?\?\?\?\?\?\?\?\?\x28 pipe \
- /usr/bin/bmptoppm 2>/dev/null
-
-# Garbage delivered from Windows via Samba
-# (donated by Andree Leidenfrost <leidenfrost@dkrz.de>)
-# 300 \033\052\157 cat
-# later changed to
-# (Bug report #22866: magicfilter: Incorrect magic for Win95/Samba print jobs)
-0 \000\000\000\000\000 cat
-
-# Sun rasterfiles
-0 \x59\xa6\x6a\x95 pipe /usr/bin/rasttopnm 2>/dev/null
-
-# SGI Imagelib (IRIS RGB) files
-0 \x1\xda pipe /usr/bin/sgitopnm 2>/dev/null
-0 \xda\x1 pipe /usr/bin/sgitopnm 2>/dev/null
-
-# FIG files; reported by Steven P. Hill <sph@uscbu.ih.att.com>
-0 \043FIG pipe /usr/bin/fig2dev -Lps -P -l dummy
-
-#
-# Standard rejects... things we don't want to print
-#
-
-# Various archive formats
-257 ustar\0 reject Attempted to print a tar file.
-257 "ustar \0" reject Attempted to print a tar file.
-0 07070 reject Attempted to print a cpio file.
-0 PK\3\4 reject Attempted to print a zip file.
-20 \xdc\xa7\xc7\xfd reject Attempted to print a zoo file.
-
-# Binaries (Linux): reject with email message
-0 \013\1d\0 reject Attempted to print a compiled binary.
-0 \100\1d\0 reject Attempted to print a compiled binary.
-0 \007\1d\0 reject Attempted to print a compiled binary.
-0 \314\0d\0 reject Attempted to print a compiled binary.
-0 \177ELF reject Attempted to print an ELF object.
-0 \007\001\0 reject Attempted to print an object file.
-216 \021\001\0\0 reject Attempted to print a core dump file.
-0 !<arch> reject Attempted to print an archive.
-0 =<ar> reject Attempted to print an archive.
-
-# Don't confuse this one with troff!
-0 .snd reject Attempted to print Sun/NeXT audio data.
-
-# wacko troff magic
-0 ''' fpipe `/usr/bin/grog -Tps $FILE`
-
-# Default entry for normal (text) files. This must be the last entry!
-# =====================================================================
-# Please adjust recode's codepage conversion manually according to your
-# local needs. We apologize for the inconveniences...
-#
-default filter /etc/magicfilter/escp-text-helper
diff --git a/net-print/magicfilter/files/StylusColor-777-Text-filter b/net-print/magicfilter/files/StylusColor-777-Text-filter
deleted file mode 100644
index fcdaf35aec6b..000000000000
--- a/net-print/magicfilter/files/StylusColor-777-Text-filter
+++ /dev/null
@@ -1,157 +0,0 @@
-#!/usr/sbin/magicfilter
-# vim:set nowrap:
-#
-# Magic filter setup file for the EPSON Stylus Color 777 printer operating
-# at 360 dpi, originally based on StylusColor-800@360dpi-filter.
-#
-# 8 July 2001 agriffis
-
-# All documents sent to the printer should be prefixed by the magic
-# command and the reset code. The 'magic command' takes the printer
-# out of the Epson packet mode communication protocol (whatever that
-# is) and enables normal data transfer. The 'reset code' discards any
-# output, ejects the existing page, and returns all settings to their
-# default.
-0 \000\000\000\033\001@EJL\ 1284.4\n@EJL\ \ \ \ \ \n\033@ cat
-
-# Native printer control codes start with <ESC>, but if this wasn't
-# recognized by the magic above, then the reset code should be
-# prefixed. Then we pass the document to the printer, cross our
-# fingers and hope for the best.
-#
-# Note that we add a ff/reset on the end just for good measure...
-0 \033 cat \000\000\000\033\001@EJL\ 1284.4\n@EJL\ \ \ \ \ \n\033@ \014\033@
-
-# PostScript, use ghostscript with the gimp-print driver. This is
-# done as a pipe (instead of a filter, which would go directly to the
-# printer) so that magicfilter can then decide whether or not a reset
-# sequence should be prefixed to the output.
-0 %! pipe /usr/bin/gs -q @stc777-text.upp -sOutputFile=- - -c quit
-0 \004%! pipe /usr/bin/gs -q @stc777-text.upp -sOutputFile=- - -c quit
-
-# PDF
-0 %PDF fpipe /usr/bin/pdftops $FILE -
-
-# TeX DVI
-0 \367\002 fpipe /usr/bin/dvips -D 360 -R -q -f
-
-# compress'd data
-0 \037\235 pipe /bin/gzip -cdq
-
-# packed, gzipped, frozen and SCO LZH data
-0 \037\036 pipe /bin/gzip -cdq
-0 \037\213 pipe /bin/gzip -cdq
-0 \037\236 pipe /bin/gzip -cdq
-0 \037\240 pipe /bin/gzip -cdq
-
-0 BZh pipe /usr/bin/bzip2 -cdq
-
-# troff documents
-0 .\?\?\040 fpipe `/usr/bin/grog -Tps $FILE`
-0 .\\\" fpipe `/usr/bin/grog -Tps $FILE`
-0 '\\\" fpipe `/usr/bin/grog -Tps $FILE`
-0 '.\\\" fpipe `/usr/bin/grog -Tps $FILE`
-0 \\\" fpipe `/usr/bin/grog -Tps $FILE`
-
-# ditroff
-0 "x T ps" pipe /usr/bin/grops
-0 "x T dvi" pipe /usr/bin/grodvi
-0 "x T ascii" pipe /usr/bin/grotty
-0 "x T latin1" pipe /usr/bin/grotty
-0 "x T lj4" reject Cannot print LaserJet 4 ditroff files.
-
-# Portable bit-, grey- and pixmaps
-0 P1\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P2\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P3\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P4\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P5\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-0 P6\n pipe /usr/bin/pnmtops -scale 1000 -dpi 360 2>/dev/null
-
-# PNG - Portable network graphics
-0 \x89PNG pipe /usr/bin/pngtopnm
-
-# HP Printer Control Language (PCL) -- assume start with reset code
-0 \033E\033 reject Cannot print PCL files on this printer.
-
-# HP Printer Job Language (PJL)
-0 \033%-12345X reject Cannot print PJL files on this printer.
-0 "@PJL " reject Cannot print PJL files on this printer.
-0 @PJL\t reject Cannot print PJL files on this printer.
-0 @PJL\r reject Cannot print PJL files on this printer.
-0 @PJL\n reject Cannot print PJL files on this printer.
-
-# GIF files
-0 GIF87a pipe /usr/bin/giftopnm 2>/dev/null
-0 GIF89a pipe /usr/bin/giftopnm 2>/dev/null
-
-# JFIF (JPEG) files
-0 \377\330\377\340\?\?JFIF\0 pipe /usr/bin/djpeg -pnm
-# Bug 40599
-0 \377\330\377\341\?\?Exif\0 pipe /usr/bin/djpeg -pnm
-
-# TIFF files (the last two bytes of the "magic" is really a version number;
-# but the magic is really lame and as far as I have understood the version
-# number has never changed and never will, so we include it.)
-0 MM\0\x2a fpipe /usr/bin/tiff2ps -a $FILE
-0 II\x2a\0 fpipe /usr/bin/tiff2ps -a $FILE
-
-# BMP files (even lousier magic -- Microsoft strikes again!)
-0 BM\?\?\?\?\?\?\?\?\?\?\?\?\x0c pipe \
- /usr/bin/bmptoppm 2>/dev/null
-0 BM\?\?\?\?\?\?\?\?\?\?\?\?\x40 pipe \
- /usr/bin/bmptoppm 2>/dev/null
-0 BM\?\?\?\?\?\?\?\?\?\?\?\?\x28 pipe \
- /usr/bin/bmptoppm 2>/dev/null
-
-# Garbage delivered from Windows via Samba
-# (donated by Andree Leidenfrost <leidenfrost@dkrz.de>)
-# 300 \033\052\157 cat
-# later changed to
-# (Bug report #22866: magicfilter: Incorrect magic for Win95/Samba print jobs)
-0 \000\000\000\000\000 cat
-
-# Sun rasterfiles
-0 \x59\xa6\x6a\x95 pipe /usr/bin/rasttopnm 2>/dev/null
-
-# SGI Imagelib (IRIS RGB) files
-0 \x1\xda pipe /usr/bin/sgitopnm 2>/dev/null
-0 \xda\x1 pipe /usr/bin/sgitopnm 2>/dev/null
-
-# FIG files; reported by Steven P. Hill <sph@uscbu.ih.att.com>
-0 \043FIG pipe /usr/bin/fig2dev -Lps -P -l dummy
-
-#
-# Standard rejects... things we don't want to print
-#
-
-# Various archive formats
-257 ustar\0 reject Attempted to print a tar file.
-257 "ustar \0" reject Attempted to print a tar file.
-0 07070 reject Attempted to print a cpio file.
-0 PK\3\4 reject Attempted to print a zip file.
-20 \xdc\xa7\xc7\xfd reject Attempted to print a zoo file.
-
-# Binaries (Linux): reject with email message
-0 \013\1d\0 reject Attempted to print a compiled binary.
-0 \100\1d\0 reject Attempted to print a compiled binary.
-0 \007\1d\0 reject Attempted to print a compiled binary.
-0 \314\0d\0 reject Attempted to print a compiled binary.
-0 \177ELF reject Attempted to print an ELF object.
-0 \007\001\0 reject Attempted to print an object file.
-216 \021\001\0\0 reject Attempted to print a core dump file.
-0 !<arch> reject Attempted to print an archive.
-0 =<ar> reject Attempted to print an archive.
-
-# Don't confuse this one with troff!
-0 .snd reject Attempted to print Sun/NeXT audio data.
-
-# wacko troff magic
-0 ''' fpipe `/usr/bin/grog -Tps $FILE`
-
-# Default entry for normal (text) files. This must be the last entry!
-# =====================================================================
-# Please adjust recode's codepage conversion manually according to your
-# local needs. We apologize for the inconveniences...
-#
-default filter /etc/magicfilter/escp-text-helper
diff --git a/net-print/magicfilter/files/digest-magicfilter-1.2 b/net-print/magicfilter/files/digest-magicfilter-1.2
deleted file mode 100644
index e60e713ad018..000000000000
--- a/net-print/magicfilter/files/digest-magicfilter-1.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 dcece221e363ca5dbc79bdd84713c04e magicfilter-1.2.tar.gz
diff --git a/net-print/magicfilter/files/escp-text-helper b/net-print/magicfilter/files/escp-text-helper
deleted file mode 100644
index d314a4bbcfbf..000000000000
--- a/net-print/magicfilter/files/escp-text-helper
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/sh
-
-# Magic command to take the printer out of the Epson packet mode
-# communication protocol (whatever that is) and enable normal data
-# transfer
-printf '\000\000\000\033\001@EJL 1284.4\n@EJL \n\033@'
-
-# Reset the printer
-printf '\033@'
-
-# Recode standard input to IBM PC characters
-#/usr/bin/recode --silent latin1..ibmpc
-cat
-
-# Eject the page
-printf '\014'
-
-# Finally, reset the printer
-printf '\033@'
diff --git a/net-print/magicfilter/magicfilter-1.2.ebuild b/net-print/magicfilter/magicfilter-1.2.ebuild
deleted file mode 100644
index b858517fa1d0..000000000000
--- a/net-print/magicfilter/magicfilter-1.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Aron Griffis <agriffis@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-print/magicfilter/magicfilter-1.2.ebuild,v 1.1 2001/09/08 14:33:06 agriffis Exp $
-
-A=magicfilter-1.2.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Customizable, extensible automatic printer filter"
-SRC_URI="ftp://metalab.unc.edu/pub/linux/system/printing/${A}"
-HOMEPAGE="http://www.gnu.org/directory/magicfilter.html"
-
-DEPEND="virtual/glibc"
-RDEPEND="virtual/glibc"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack ${A}
- # This is the patch directly from the Debian package. It's included
- # here (instead of fetching from Debian) because their package
- # revisions will change faster than this ebuild will keep up...
- cd ${S}
- patch -p1 < ${FILESDIR}/magicfilter_1.2-39.diff
-}
-
-src_compile() {
- cd ${S}
- ./configure --host="${CHOST}" || die
- emake
- # Fixup the filters for /usr/sbin/magicfilter
- cd filters
- for f in *-filter; do
- mv $f $f.old
- ( read l; echo '#!/usr/sbin/magicfilter'; cat ) <$f.old >$f
- done
-}
-
-src_install() {
- cd ${S}
- dodir /usr/sbin /usr/share/man/man8 /etc/magicfilter
- install -m 755 magicfilter ${D}/usr/sbin
- install -m 755 magicfilter.man ${D}/usr/share/man/man8/magicfilter.8
- install -m 755 magicfilterconfig ${D}/usr/sbin
- install -m 644 magicfilterconfig.8 ${D}/usr/share/man
- cp -p filters/*-filter ${D}/etc/magicfilter
- # Should these eventually be made into a patch...?
- install -m 755 ${FILESDIR}/*-filter ${D}/etc/magicfilter
- install -m 755 ${FILESDIR}/escp-text-helper ${D}/etc/magicfilter
- gzip -9f ${D}/usr/share/man/*/*
- gzip -9f filters/README*
- dodoc README QuickInst TODO debian/copyright
- docinto filters
- dodoc filters/README*
-}