summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/qt/ChangeLog6
-rw-r--r--x11-libs/qt/qt-4.0.1.ebuild10
2 files changed, 11 insertions, 5 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index ef58aafb0287..66ac083467a8 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.241 2005/08/22 13:13:47 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.242 2005/08/22 13:22:01 greg_g Exp $
+
+ 22 Aug 2005; Gregorio Guidi <greg_g@gentoo.org> qt-4.0.1.ebuild:
+ Fix bug #75181 in a more generic way, that does not make assumptions on the
+ build spec.
22 Aug 2005; Gregorio Guidi <greg_g@gentoo.org>
+files/qt-3.3.4-gcc4-volatile.patch, qt-3.3.4-r7.ebuild:
diff --git a/x11-libs/qt/qt-4.0.1.ebuild b/x11-libs/qt/qt-4.0.1.ebuild
index 38412c0071f4..e4e0f60c44e1 100644
--- a/x11-libs/qt/qt-4.0.1.ebuild
+++ b/x11-libs/qt/qt-4.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.0.1.ebuild,v 1.1 2005/08/19 14:52:16 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.0.1.ebuild,v 1.2 2005/08/22 13:22:01 greg_g Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -67,8 +67,7 @@ src_unpack() {
cd ${S}
- cp configure configure.orig
- sed -e 's:read acceptance:acceptance=yes:' configure.orig > configure
+ sed -i -e 's:read acceptance:acceptance=yes:' configure
cd mkspecs/$(qt_mkspecs_dir)
# set c/xxflags and ldflags
@@ -82,9 +81,12 @@ src_unpack() {
-e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
-e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
qmake.conf
+
+ # Do not link with -rpath. See bug #75181.
+ sed -i -e "s:QMAKE_RPATH.*=.*:QMAKE_RPATH=:" \
+ qmake.conf
cd ${S}
- epatch ${FILESDIR}/qt4-rpath.patch
epatch ${FILESDIR}/qt4-nomkdir.patch
if [[ $(gcc-major-version = "4") ]]; then