summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/yajl/ChangeLog7
-rw-r--r--dev-libs/yajl/yajl-1.0.11.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-libs/yajl/ChangeLog b/dev-libs/yajl/ChangeLog
index 856ab961c5fd..d897644874ce 100644
--- a/dev-libs/yajl/ChangeLog
+++ b/dev-libs/yajl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/yajl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/ChangeLog,v 1.1 2010/05/23 22:31:59 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/ChangeLog,v 1.2 2010/10/15 17:50:22 ssuominen Exp $
+
+*yajl-1.0.11 (15 Oct 2010)
+
+ 15 Oct 2010; Samuli Suominen <ssuominen@gentoo.org> +yajl-1.0.11.ebuild:
+ Version bump.
*yajl-1.0.9-r1 (23 May 2010)
diff --git a/dev-libs/yajl/yajl-1.0.11.ebuild b/dev-libs/yajl/yajl-1.0.11.ebuild
new file mode 100644
index 000000000000..1704311895ef
--- /dev/null
+++ b/dev-libs/yajl/yajl-1.0.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/yajl-1.0.11.ebuild,v 1.1 2010/10/15 17:50:22 ssuominen Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="Small event-driven (SAX-style) JSON parser"
+HOMEPAGE="http://lloyd.github.com/yajl/"
+SRC_URI="http://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+CMAKE_IN_SOURCE_BUILD="1"
+
+src_prepare() {
+ cd "${WORKDIR}"/lloyd-${PN}-*
+ S=$(pwd)
+
+ epatch "${FILESDIR}"/${PN}-fix_tests.patch
+}
+
+src_test() {
+ emake test || die
+}