summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/ocaml-make/ChangeLog9
-rw-r--r--dev-ml/ocaml-make/ocaml-make-6.30.0.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-ml/ocaml-make/ChangeLog b/dev-ml/ocaml-make/ChangeLog
index 29d355f00cdb..9d8b7445e411 100644
--- a/dev-ml/ocaml-make/ChangeLog
+++ b/dev-ml/ocaml-make/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-make
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-make/ChangeLog,v 1.12 2009/06/21 11:54:53 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-make/ChangeLog,v 1.13 2011/04/19 18:39:29 aballier Exp $
+
+*ocaml-make-6.30.0 (19 Apr 2011)
+
+ 19 Apr 2011; Alexis Ballier <aballier@gentoo.org> +ocaml-make-6.30.0.ebuild:
+ version bump
*ocaml-make-6.29.3 (21 Jun 2009)
diff --git a/dev-ml/ocaml-make/ocaml-make-6.30.0.ebuild b/dev-ml/ocaml-make/ocaml-make-6.30.0.ebuild
new file mode 100644
index 000000000000..f2806b2aaa0e
--- /dev/null
+++ b/dev-ml/ocaml-make/ocaml-make-6.30.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-make/ocaml-make-6.30.0.ebuild,v 1.1 2011/04/19 18:39:29 aballier Exp $
+
+DESCRIPTION="Generic O'Caml Makefile for GNU Make"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+LICENSE="LGPL-2.1"
+
+DEPEND=""
+RDEPEND=">=dev-lang/ocaml-3.06-r1
+ >=dev-ml/findlib-0.8"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+src_install () {
+ # Just put the OCamlMakefile into /usr/include
+ # where GNU Make will automatically pick it up.
+ insinto /usr/include
+ doins OCamlMakefile
+ # install documentation
+ dodoc README.txt Changelog
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r calc camlp4 gtk idl threads
+ fi
+}