summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/mongo/ChangeLog10
-rw-r--r--dev-ruby/mongo/metadata.xml5
-rw-r--r--dev-ruby/mongo/mongo-1.5.2.ebuild46
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/mongo/ChangeLog b/dev-ruby/mongo/ChangeLog
new file mode 100644
index 000000000000..a8d1daa31f3c
--- /dev/null
+++ b/dev-ruby/mongo/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/mongo
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongo/ChangeLog,v 1.1 2011/12/28 23:56:06 flameeyes Exp $
+
+*mongo-1.5.2 (28 Dec 2011)
+
+ 28 Dec 2011; Diego E. Pettenò <flameeyes@gentoo.org> +metadata.xml,
+ +mongo-1.5.2.ebuild:
+ Initial import of ebuild for mongo driver.
+
diff --git a/dev-ruby/mongo/metadata.xml b/dev-ruby/mongo/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/mongo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/mongo/mongo-1.5.2.ebuild b/dev-ruby/mongo/mongo-1.5.2.ebuild
new file mode 100644
index 000000000000..309654cb9fa9
--- /dev/null
+++ b/dev-ruby/mongo/mongo-1.5.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongo/mongo-1.5.2.ebuild,v 1.1 2011/12/28 23:56:06 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="mongodb"
+GITHUB_PROJECT="mongo-ruby-driver"
+RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby driver for MongoDB."
+HOMEPAGE="http://www.mongodb.org/"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/${PV} -> ${GITHUB_PROJECT}-${PV}.tar.gz"
+
+LICENSE="APSL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# This is the same source package as bson, so keep them the same
+# version, but not revision
+ruby_add_rdepend "~dev-ruby/bson-${PV}"
+
+ruby_add_bdepend \
+ "test? (
+ dev-ruby/rake
+ dev-ruby/shoulda
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # remove the stuff that is actually part of dev-ruby/bson
+ rm -rf lib/bson* bin/{b2j,j2b}son
+}