summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog7
-rw-r--r--x11-terms/rxvt-unicode/files/macosx-clipboard71
-rw-r--r--x11-terms/rxvt-unicode/files/rxvt-unicode-9.06-case-insensitive-fs.patch10
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.12.ebuild13
4 files changed, 97 insertions, 4 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 5aff11ca4ab5..0599ba469f46 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.188 2011/07/02 06:30:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.189 2011/07/03 18:53:24 wired Exp $
+
+ 03 Jul 2011; Alex Alexander <wired@gentoo.org>
+ +files/rxvt-unicode-9.06-case-insensitive-fs.patch, rxvt-unicode-9.12.ebuild,
+ +files/macosx-clipboard:
+ prefix support
*rxvt-unicode-9.12 (02 Jul 2011)
diff --git a/x11-terms/rxvt-unicode/files/macosx-clipboard b/x11-terms/rxvt-unicode/files/macosx-clipboard
new file mode 100644
index 000000000000..9e149586aa4c
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/macosx-clipboard
@@ -0,0 +1,71 @@
+#! perl -w
+
+# ----------------------------------------------------------------------
+# File: macosx-clipboard
+# ----------------------------------------------------------------------
+#
+# All portions of code are copyright by their respective author/s.
+# Copyright (c) 2006 Samuel Ljungkvist <salj@triplefusion.net>
+# 2009 Reza Jelveh <reza.jelveh@gmail.com>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# ----------------------------------------------------------------------
+
+# Usage:
+
+# URxvt.perl-ext-common: macosx-clipboard
+# URxvt.keysym.M-c: perl:macosx-clipboard:copy
+# URxvt.keysym.M-v: perl:macosx-clipboard:paste
+
+use Fcntl ();
+use Mac::Pasteboard;
+use locale;
+use utf8;
+
+our($pasteboard);
+
+$pasteboard = Mac::Pasteboard->new ();
+
+sub copy {
+ my ($self) = @_;
+
+ $pasteboard->clear ();
+ $pasteboard->copy ($self->selection);
+ ()
+}
+
+sub paste {
+ my ($self) = @_;
+ my ($str);
+
+ $str = $pasteboard->paste();
+ utf8::decode($str);
+ $self->tt_write($self->locale_encode($str));
+ ()
+}
+
+sub on_user_command {
+ my ($self, $cmd) = @_;
+
+ if ($cmd eq "macosx-clipboard:copy") {
+ $self->copy;
+ }
+
+ if ($cmd eq "macosx-clipboard:paste") {
+ $self->paste;
+ }
+ ()
+}
+
diff --git a/x11-terms/rxvt-unicode/files/rxvt-unicode-9.06-case-insensitive-fs.patch b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.06-case-insensitive-fs.patch
new file mode 100644
index 000000000000..49fa01adc348
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.06-case-insensitive-fs.patch
@@ -0,0 +1,10 @@
+Avoid "make: `install' is up to date." on case insensitive filesystems
+
+--- Makefile.in
++++ Makefile.in
+@@ -86,3 +86,5 @@
+ dist: tar.bz2
+
+ # ------------------------------------------------------------------------
++
++.PHONY: install
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.12.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.12.ebuild
index ba8bce4c268a..245be539bafc 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9.12.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.12.ebuild,v 1.1 2011/07/02 06:30:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.12.ebuild,v 1.2 2011/07/03 18:53:24 wired Exp $
EAPI="4"
@@ -12,7 +12,7 @@ SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
IUSE="
256-color alt-font-width afterimage blink +focused-urgency fading-colors
+font-styles force-hints iso14755 +mousewheel perl pixbuf truetype unicode3
@@ -25,7 +25,8 @@ RDEPEND="x11-libs/libX11
>=sys-libs/ncurses-5.7-r6
afterimage? ( || ( media-libs/libafterimage x11-wm/afterstep ) )
perl? ( dev-lang/perl )
- pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )"
+ pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )
+ kernel_Darwin? ( dev-perl/Mac-Pasteboard )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
x11-proto/xproto"
@@ -33,6 +34,12 @@ DEPEND="${RDEPEND}
REQUIRED_USE="vanilla? ( !alt-font-width focused-urgency !force-hints !wcwidth )"
src_prepare() {
+ if use kernel_Darwin; then
+ cp "${FILESDIR}"/macosx-clipboard src/perl/ || die
+ fi
+ # fix for prefix not installing properly
+ epatch "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch
+
if ! use afterimage && ! use pixbuf; then
einfo " + If you want transparency support, please enable either the *pixbuf*"
einfo " or the *afterimage* USE flag. Enabling both will default to pixbuf."