summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/gtk+/ChangeLog6
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.6.4-r13
-rw-r--r--x11-libs/gtk+/files/gtk+-2.6.4-bmp_reject_corrupt.patch45
-rw-r--r--x11-libs/gtk+/gtk+-2.6.4-r1.ebuild113
-rw-r--r--x11-libs/gtk+/gtk+-2.6.8.ebuild4
5 files changed, 7 insertions, 164 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index ac0b03a88004..1139dc594a3f 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.176 2005/08/23 21:33:37 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.177 2005/08/25 03:18:08 leonardop Exp $
+
+ 25 Aug 2005; Leonardo Boshell <leonardop@gentoo.org>
+ gtk+-2.6.8.ebuild:
+ Stable on x86.
23 Aug 2005; Aron Griffis <agriffis@gentoo.org> gtk+-2.6.7.ebuild:
stable on ia64
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.6.4-r1 b/x11-libs/gtk+/files/digest-gtk+-2.6.4-r1
deleted file mode 100644
index 2525cd8498ef..000000000000
--- a/x11-libs/gtk+/files/digest-gtk+-2.6.4-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 4749fce7b082b784a71a076aa586dc25 gtk+-2.6.4.tar.bz2 11222426
-MD5 ea90aff86c5f7d059bceb6b3550e6aac gtk+-2.6-smoothscroll-r2.patch 26277
-MD5 5a046e852e4a0145197fca14969dcd4d gtk+-2.6.1-lib64.patch.bz2 6047
diff --git a/x11-libs/gtk+/files/gtk+-2.6.4-bmp_reject_corrupt.patch b/x11-libs/gtk+/files/gtk+-2.6.4-bmp_reject_corrupt.patch
deleted file mode 100644
index be3c8231d087..000000000000
--- a/x11-libs/gtk+/files/gtk+-2.6.4-bmp_reject_corrupt.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-===================================================================
-RCS file: /cvs/gnome/gtk+/gdk-pixbuf/io-bmp.c,v
-retrieving revision 1.46
-retrieving revision 1.46.2.2
-diff -u -r1.46 -r1.46.2.2
---- io-bmp.c 2005/01/04 15:47:02 1.46
-+++ io-bmp.c 2005/03/28 04:12:32 1.46.2.2
-@@ -219,7 +219,19 @@
- static gboolean grow_buffer (struct bmp_progressive_state *State,
- GError **error)
- {
-- guchar *tmp = g_try_realloc (State->buff, State->BufferSize);
-+ guchar *tmp;
-+
-+ if (State->BufferSize == 0) {
-+ g_set_error (error,
-+ GDK_PIXBUF_ERROR,
-+ GDK_PIXBUF_ERROR_CORRUPT_IMAGE,
-+ _("BMP image has bogus header data"));
-+ State->read_state = READ_STATE_ERROR;
-+ return FALSE;
-+ }
-+
-+ tmp = g_try_realloc (State->buff, State->BufferSize);
-+
- if (!tmp) {
- g_set_error (error,
- GDK_PIXBUF_ERROR,
-@@ -228,6 +240,7 @@
- State->read_state = READ_STATE_ERROR;
- return FALSE;
- }
-+
- State->buff = tmp;
- return TRUE;
- }
-@@ -1031,7 +1044,7 @@
- gint new_y = MIN (context->compr.y, context->Header.height);
- (*context->updated_func) (context->pixbuf,
- 0,
-- y,
-+ context->Header.height - new_y,
- context->Header.width,
- new_y - y,
- context->user_data);
diff --git a/x11-libs/gtk+/gtk+-2.6.4-r1.ebuild b/x11-libs/gtk+/gtk+-2.6.4-r1.ebuild
deleted file mode 100644
index cb182dfbf0c7..000000000000
--- a/x11-libs/gtk+/gtk+-2.6.4-r1.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.6.4-r1.ebuild,v 1.10 2005/07/09 15:31:33 swegener Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Gimp ToolKit +"
-HOMEPAGE="http://www.gtk.org/"
-SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.6/${P}.tar.bz2
- mirror://gentoo/gtk+-2.6-smoothscroll-r2.patch
- amd64? ( http://dev.gentoo.org/~kingtaco/gtk+-2.6.1-lib64.patch.bz2 )"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
-IUSE="doc tiff jpeg static"
-
-RDEPEND="virtual/x11
- >=dev-libs/glib-2.6
- >=dev-libs/atk-1.0.1
- >=x11-libs/pango-1.8
- x11-misc/shared-mime-info
- >=media-libs/libpng-1.2.1
- jpeg? ( >=media-libs/jpeg-6b-r2 )
- tiff? ( >=media-libs/tiff-3.5.7 )"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.12.0
- sys-devel/autoconf
- >=sys-devel/automake-1.7.9
- doc? ( >=dev-util/gtk-doc-1 )
- !x11-themes/gtk-engines-pixmap"
-
-src_unpack() {
-
- unpack ${A}
-
- cd ${S}
- # beautifying patch for disabled icons
- epatch ${FILESDIR}/${PN}-2.2.1-disable_icons_smooth_alpha.patch
- # add smoothscroll support for usability reasons
- # http://bugzilla.gnome.org/show_bug.cgi?id=103811
- epatch ${DISTDIR}/${PN}-2.6-smoothscroll-r2.patch
-
- cd ${S}/gdk-pixbuf
- # fix #86979
- epatch ${FILESDIR}/${P}-bmp_reject_corrupt.patch
-
- cd ${S}
- # use an arch-specific config directory so that 32bit and 64bit versions
- # dont clash on multilib systems
- use amd64 && epatch ${DISTDIR}/gtk+-2.6.1-lib64.patch.bz2
- # and this line is just here to make building emul-linux-x86-gtklibs a bit
- # easier, so even this should be amd64 specific.
- use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && epatch ${DISTDIR}/gtk+-2.6.1-lib64.patch.bz2
-
- # patch for ppc64 (#64359)
- use ppc64 && epatch ${FILESDIR}/${PN}-2.4.9-ppc64.patch
- use ppc64 && append-flags -mminimal-toc
-
- autoconf || die
- automake || die
-
- epunt_cxx
-
-}
-
-src_compile() {
-
- # bug 8762
- replace-flags "-O3" "-O2"
-
- econf \
- `use_enable doc gtk-doc` \
- `use_with jpeg libjpeg` \
- `use_with tiff libtiff` \
- `use_enable static` \
- --with-png \
- --with-gdktarget=x11 \
- --with-xinput \
- || die
-
- # gtk+ isn't multithread friendly due to some obscure code generation bug
- emake -j1 || die
-
-}
-
-src_install() {
-
- dodir /etc/gtk-2.0
- use amd64 && dodir /etc/gtk-2.0/${CHOST}
- use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && dodir /etc/gtk-2.0/${CHOST}
-
- make DESTDIR=${D} install || die
-
- # Enable xft in environment as suggested by <utx@gentoo.org>
- dodir /etc/env.d
- echo "GDK_USE_XFT=1" >${D}/etc/env.d/50gtk2
-
- dodoc AUTHORS ChangeLog* HACKING NEWS* README*
-
-}
-
-pkg_postinst() {
-
- use amd64 && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
- use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
- GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
-
- gtk-query-immodules-2.0 > /${GTK2_CONFDIR}/gtk.immodules
- gdk-pixbuf-query-loaders > /${GTK2_CONFDIR}/gdk-pixbuf.loaders
-
-}
diff --git a/x11-libs/gtk+/gtk+-2.6.8.ebuild b/x11-libs/gtk+/gtk+-2.6.8.ebuild
index a58d9d7a6650..9afaa1831911 100644
--- a/x11-libs/gtk+/gtk+-2.6.8.ebuild
+++ b/x11-libs/gtk+/gtk+-2.6.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.6.8.ebuild,v 1.2 2005/07/09 15:31:33 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.6.8.ebuild,v 1.3 2005/08/25 03:18:08 leonardop Exp $
inherit flag-o-matic eutils
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.6/${P}.tar.bz2
LICENSE="LGPL-2"
SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86"
IUSE="doc tiff jpeg static"
RDEPEND="virtual/x11