summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/cairo/ChangeLog9
-rw-r--r--x11-libs/cairo/cairo-1.0.4-r1.ebuild59
-rw-r--r--x11-libs/cairo/files/cairo-1.0.4-ssp-nonsense.patch18
-rw-r--r--x11-libs/cairo/files/digest-cairo-1.0.4-r13
4 files changed, 88 insertions, 1 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index fd3d84d41998..ecf83d2fdbab 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.80 2006/08/26 01:06:47 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.81 2006/10/12 15:27:59 blubb Exp $
+
+*cairo-1.0.4-r1 (12 Oct 2006)
+
+ 12 Oct 2006; Simon Stelling <blubb@gentoo.org>
+ +files/cairo-1.0.4-ssp-nonsense.patch, +cairo-1.0.4-r1.ebuild:
+ fix problems with -fstack-protector on amd64 with a strange patch from bug
+ 109480; credit goes to Hopeless
*cairo-1.2.4 (26 Aug 2006)
diff --git a/x11-libs/cairo/cairo-1.0.4-r1.ebuild b/x11-libs/cairo/cairo-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..bfeeb4550579
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.0.4-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.0.4-r1.ebuild,v 1.1 2006/10/12 15:27:59 blubb Exp $
+
+inherit eutils
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc glitz png X"
+# bug 118106: not entirely broken, just too flakey
+RESTRICT="test"
+
+RDEPEND="media-libs/fontconfig
+ >=media-libs/freetype-2.1
+ X? ( || ( ( x11-libs/libXrender
+ x11-libs/libX11 )
+ virtual/x11 )
+ virtual/xft )
+ glitz? ( =media-libs/glitz-0.4.4* )
+ png? ( media-libs/libpng )
+ !<x11-libs/cairo-0.2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ X? ( || ( x11-proto/renderproto virtual/x11 ) )
+ doc? ( >=dev-util/gtk-doc-1.3
+ ~app-text/docbook-xml-dtd-4.2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}"/${P}-ssp-nonsense.patch #109480
+}
+
+src_compile() {
+
+ econf $(use_enable X xlib) \
+ $(use_enable png) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable glitz) \
+ --enable-freetype || die "./configure failed"
+
+ emake || die "Compilation failed"
+
+}
+
+src_install() {
+
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+}
diff --git a/x11-libs/cairo/files/cairo-1.0.4-ssp-nonsense.patch b/x11-libs/cairo/files/cairo-1.0.4-ssp-nonsense.patch
new file mode 100644
index 000000000000..9e8efe903847
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-1.0.4-ssp-nonsense.patch
@@ -0,0 +1,18 @@
+--- cairo-1.0.2.orig/src/cairo-path-stroke.c 2005-10-03 21:44:43.000000000 +0100
++++ cairo-1.0.2/src/cairo-path-stroke.c 2006-01-27 01:50:06.000000000 +0000
+@@ -180,6 +180,7 @@
+ cairo_gstate_t *gstate = stroker->gstate;
+ int clockwise = _cairo_stroker_face_clockwise (out, in);
+ cairo_point_t *inpt, *outpt;
++ cairo_polygon_t polygon;
+
+ if (in->cw.x == out->cw.x
+ && in->cw.y == out->cw.y
+@@ -271,7 +272,6 @@
+ double x1, y1, x2, y2;
+ double mx, my;
+ double dx1, dx2, dy1, dy2;
+- cairo_polygon_t polygon;
+ cairo_point_t outer;
+
+ /*
diff --git a/x11-libs/cairo/files/digest-cairo-1.0.4-r1 b/x11-libs/cairo/files/digest-cairo-1.0.4-r1
new file mode 100644
index 000000000000..cb0dba37b278
--- /dev/null
+++ b/x11-libs/cairo/files/digest-cairo-1.0.4-r1
@@ -0,0 +1,3 @@
+MD5 9002b0e69b3f94831a22d3f2a7735ce2 cairo-1.0.4.tar.gz 1475777
+RMD160 40403971bcb6ed9cd4379e8e13a52f515db886cb cairo-1.0.4.tar.gz 1475777
+SHA256 2c54f7a452bd21ae99789e36d38135b0ea43e7238648aabd13476d1868dcd2f5 cairo-1.0.4.tar.gz 1475777