summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/postgresql/ChangeLog5
-rw-r--r--dev-db/postgresql/postgresql-8.1.0.ebuild4
2 files changed, 6 insertions, 3 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index 58fb94afd9b8..fb3f298717f2 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.251 2005/11/21 18:45:01 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.252 2005/11/23 04:12:06 nakano Exp $
+
+ 23 Nov 2005; Masatomo Nakano <nakano@gentoo.org> postgresql-8.1.0.ebuild:
+ Fixed version check logic for 8.1. (#72814)
21 Nov 2005; Joseph Jezak <josejx@gentoo.org> postgresql-7.3.11.ebuild,
postgresql-7.4.9.ebuild, postgresql-8.0.4.ebuild:
diff --git a/dev-db/postgresql/postgresql-8.1.0.ebuild b/dev-db/postgresql/postgresql-8.1.0.ebuild
index 7cf96bac4e07..52cdbbc5a51c 100644
--- a/dev-db/postgresql/postgresql-8.1.0.ebuild
+++ b/dev-db/postgresql/postgresql-8.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.1.0.ebuild,v 1.3 2005/11/12 23:09:52 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.1.0.ebuild,v 1.4 2005/11/23 04:12:06 nakano Exp $
inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs
@@ -49,7 +49,7 @@ pkg_setup() {
if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
PG_MAJOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f1 -d.`
PG_MINOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f2 -d.`
- if [ ${PG_MAJOR} -lt 8 ] || [ ${PG_MAJOR} -eq 8 -a ${PG_MINOR} -lt 0 ] ; then
+ if [ ${PG_MAJOR} -lt 8 ] || [ ${PG_MAJOR} -eq 8 -a ${PG_MINOR} -lt 1 ] ; then
eerror "Postgres ${PV} cannot upgrade your existing databases, you must"
eerror "use pg_dump to export your existing databases to a file, and then"
eerror "pg_restore to import them when you have upgraded completely."