summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/alsa-driver/ChangeLog8
-rw-r--r--media-sound/alsa-driver/Manifest4
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.0_rc1.ebuild90
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.0_rc11
4 files changed, 100 insertions, 3 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 37b41aa5595a..dee6eebe8172 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.60 2003/11/26 16:38:57 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.61 2003/12/02 18:33:27 mholzer Exp $
+
+*alsa-driver-1.0.0_rc1 (02 Dec 2003)
+
+ 02 Dec 2003; Martin Holzer <mholzer@gentoo.org>
+ alsa-driver-1.0.0_rc1.ebuild:
+ Version bumped.
26 Nov 2003; Martin Holzer <mholzer@gentoo.org> alsa-driver-0.9.8.ebuild:
marked x86 stable.
diff --git a/media-sound/alsa-driver/Manifest b/media-sound/alsa-driver/Manifest
index d6055b9707b0..20e4d97f4834 100644
--- a/media-sound/alsa-driver/Manifest
+++ b/media-sound/alsa-driver/Manifest
@@ -1,10 +1,10 @@
MD5 a0d2f9e64f89d3fea2a09767bb1eb6a2 alsa-driver-0.5.12a.ebuild 1663
-MD5 2a82bdecc2de501dcc0ec865312d2572 alsa-driver-1.0.0_rc1.ebuild 2297
+MD5 942c9b2d66d49a8de73a280d499252c8 alsa-driver-1.0.0_rc1.ebuild 2417
MD5 564c18904e8745681363862186b42ec6 alsa-driver-0.9.8.ebuild 2180
MD5 cc589e7d9e700047214372dbe1eb3917 alsa-driver-0.9.2.ebuild 2686
MD5 ca02c9ed0add3aefaa8c0a5368750fc3 alsa-driver-0.9.0_rc2.ebuild 2655
MD5 e1147a642867b3b3ea43518a1376f6d2 metadata.xml 250
-MD5 844453664fd17a5bc8de8f6c68e219b6 ChangeLog 10534
+MD5 9b5aa15051074db384280514860e155e ChangeLog 10673
MD5 1db42ce7b2e44fae027840e464f71334 files/digest-alsa-driver-1.0.0_rc1 74
MD5 8c81382138ab9223d1e0abdfdb1e5e98 files/alsa-modules.conf 1088
MD5 aa25f4bdd7880c4cdd0a71b1f691922d files/alsa-compile-fix 746
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.0_rc1.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.0_rc1.ebuild
new file mode 100644
index 000000000000..9c16da41f288
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-1.0.0_rc1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.0_rc1.ebuild,v 1.1 2003/12/02 18:33:27 mholzer Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+LICENSE="GPL-2 LGPL-2.1"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment to a space-separated list of drivers that you want to build.
+# For example:
+#
+# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+#
+[ x"${ALSA_CARDS}" = x ] && ALSA_CARDS=all
+
+IUSE="oss"
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ virtual/linux-sources
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+PROVIDE="virtual/alsa"
+
+SLOT="${KV}"
+KEYWORDS="~x86 ~ppc"
+
+MY_P=${P/_rc/rc}
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${MY_P}.tar.bz2"
+#SRC_URI="mirror://alsaproject/driver/${P}.tar.bz2"
+#RESTRICT="nomirror"
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ ewarn "This does not work with kernel 2.6 !!!"
+ ewarn "Please use the kernel modules instead of this the package"
+ # The makefile still installs an alsasound initscript,
+ # which we REALLY dont want.
+ # This patch stops that
+ epatch ${FILESDIR}/makefile.patch || die "Makefile patch failed"
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+
+ myconf=""
+ use oss && myconf="$myconf --with-oss=yes" || \
+ myconf="$myconf --with-oss=no"
+
+ ./configure \
+ $myconf \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-cards="${ALSA_CARDS}" \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+
+src_install() {
+ dodir /usr/include/sound
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use the 'alsamixer' program to unmute them."
+ einfo
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.0_rc1 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.0_rc1
new file mode 100644
index 000000000000..f4d94af1899c
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.0_rc1
@@ -0,0 +1 @@
+MD5 2fcbfbf90950f520ed42ae639e9333a6 alsa-driver-1.0.0rc1.tar.bz2 1656755