summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/seatris/ChangeLog9
-rw-r--r--games-puzzle/seatris/files/seatris-0.0.14-as-needed.patch4
-rw-r--r--games-puzzle/seatris/seatris-0.0.14.ebuild22
3 files changed, 21 insertions, 14 deletions
diff --git a/games-puzzle/seatris/ChangeLog b/games-puzzle/seatris/ChangeLog
index 8efeb8e7ddb6..afb8552d1cae 100644
--- a/games-puzzle/seatris/ChangeLog
+++ b/games-puzzle/seatris/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/seatris
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/seatris/ChangeLog,v 1.8 2009/02/10 11:55:04 tupone Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/seatris/ChangeLog,v 1.9 2014/10/30 22:18:33 jer Exp $
+
+ 30 Oct 2014; Jeroen Roovers <jer@gentoo.org>
+ files/seatris-0.0.14-as-needed.patch, seatris-0.0.14.ebuild:
+ Fix building against sys-libs/ncurses[tinfo] (bug #526582).
10 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
+files/seatris-0.0.14-as-needed.patch, seatris-0.0.14.ebuild:
@@ -30,4 +34,3 @@
11 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+seatris-0.0.14.ebuild:
initial commit - in response to bug #54939
-
diff --git a/games-puzzle/seatris/files/seatris-0.0.14-as-needed.patch b/games-puzzle/seatris/files/seatris-0.0.14-as-needed.patch
index 1cd22fb52fd9..e77c0dd75077 100644
--- a/games-puzzle/seatris/files/seatris-0.0.14-as-needed.patch
+++ b/games-puzzle/seatris/files/seatris-0.0.14-as-needed.patch
@@ -1,5 +1,5 @@
---- Makefile.in.old 2009-02-10 12:54:35.000000000 +0100
-+++ Makefile.in 2009-02-10 12:55:16.000000000 +0100
+--- a/Makefile.in
++++ b/Makefile.in
@@ -11,7 +11,7 @@
parse.o readcfg.o
diff --git a/games-puzzle/seatris/seatris-0.0.14.ebuild b/games-puzzle/seatris/seatris-0.0.14.ebuild
index 381d0e689e09..48984f9d6a76 100644
--- a/games-puzzle/seatris/seatris-0.0.14.ebuild
+++ b/games-puzzle/seatris/seatris-0.0.14.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/seatris/seatris-0.0.14.ebuild,v 1.10 2009/02/10 11:55:04 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/seatris/seatris-0.0.14.ebuild,v 1.11 2014/10/30 22:18:33 jer Exp $
-EAPI=2
-inherit eutils games
+EAPI=5
+inherit eutils games toolchain-funcs
DESCRIPTION="A color ncurses tetris clone"
HOMEPAGE="http://www.earth.li/projectpurple/progs/seatris.html"
@@ -12,20 +12,24 @@ SRC_URI="http://www.earth.li/projectpurple/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ppc64 x86"
-IUSE=""
-DEPEND="sys-libs/ncurses"
+RDEPEND="sys-libs/ncurses"
+DEPEND="${DEPEND}"
src_prepare() {
sed -i \
-e "s:/var/lib/games:${GAMES_STATEDIR}:" \
- scoring.h seatris.6 \
- || die "sed failed"
+ scoring.h seatris.6 || die
+
epatch "${FILESDIR}"/${P}-as-needed.patch
}
+src_compile() {
+ emake LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
+}
+
src_install () {
- dogamesbin seatris || die "dogamesbin failed"
+ dogamesbin seatris || die
doman seatris.6
dodoc ACKNOWLEDGEMENTS HISTORY README TODO example.seatrisrc
dodir "${GAMES_STATEDIR}"