summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/arora/ChangeLog10
-rw-r--r--www-client/arora/arora-0.3.ebuild28
-rw-r--r--www-client/arora/arora-0.5.ebuild66
3 files changed, 74 insertions, 30 deletions
diff --git a/www-client/arora/ChangeLog b/www-client/arora/ChangeLog
index d78973c9296a..d80798662ecb 100644
--- a/www-client/arora/ChangeLog
+++ b/www-client/arora/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/arora
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.8 2008/11/06 00:58:12 yngwin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.9 2009/02/21 10:35:32 yngwin Exp $
+
+*arora-0.5 (21 Feb 2009)
+
+ 21 Feb 2009; Ben de Groot <yngwin@gentoo.org> -arora-0.3.ebuild,
+ +arora-0.5.ebuild:
+ Version bump. Bring linguas up to date. Remove old.
06 Nov 2008; Ben de Groot <yngwin@gentoo.org> arora-0.4.ebuild:
Die when make install fails, fixes bug 245454. And not allowing parallel
diff --git a/www-client/arora/arora-0.3.ebuild b/www-client/arora/arora-0.3.ebuild
deleted file mode 100644
index 4ae3ed39cc22..000000000000
--- a/www-client/arora/arora-0.3.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/arora/arora-0.3.ebuild,v 1.1 2008/08/05 05:32:04 yngwin Exp $
-
-EAPI=1
-inherit eutils qt4
-
-DESCRIPTION="A cross-platform Qt4 WebKit browser"
-HOMEPAGE="http://arora.googlecode.com/"
-SRC_URI="http://arora.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="|| ( GPL-3 GPL-2 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=x11-libs/qt-webkit-4.4.0:4"
-DEPEND="${RDEPEND}"
-
-src_compile() {
- eqmake4 arora.pro PREFIX="${D}/usr" || die "qmake failed"
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog README
-}
diff --git a/www-client/arora/arora-0.5.ebuild b/www-client/arora/arora-0.5.ebuild
new file mode 100644
index 000000000000..315fb3ec80d3
--- /dev/null
+++ b/www-client/arora/arora-0.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/arora-0.5.ebuild,v 1.1 2009/02/21 10:35:32 yngwin Exp $
+
+EAPI=2
+inherit eutils qt4
+
+DESCRIPTION="A cross-platform Qt4 WebKit browser"
+HOMEPAGE="http://arora.googlecode.com/"
+SRC_URI="http://arora.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/qt-webkit:4"
+DEPEND="$RDEPEND"
+
+ARORA_LANGS="en_US es es_CR et_EE fr_CA gl ms nb_NO uk zh_CN"
+ARORA_NOLONGLANGS="cs_CZ da_DK de_DE fr_FR he_IL hu_HU it_IT ja_JP nl_NL pl_PL
+ ru_RU sk_SK tr_TR"
+
+for L in $ARORA_LANGS; do
+ IUSE="$IUSE linguas_$L"
+done
+for L in $ARORA_NOLONGLANGS; do
+ IUSE="$IUSE linguas_${L%_*}"
+done
+
+src_prepare() {
+ # process linguas
+ local langs=
+ for lingua in $LINGUAS; do
+ if has $lingua $ARORA_LANGS; then
+ langs="$langs ${lingua}.ts"
+ else
+ for a in $ARORA_NOLONGLANGS; do
+ if [[ $lingua == ${a%_*} ]]; then
+ langs="$langs ${a}.ts"
+ fi
+ done
+ fi
+ done
+
+ # remove all translations, then add only the ones we want
+ sed -i '/ts/d' src/locale/locale.pri || die 'sed failed'
+ sed -i "/^TRANSLATIONS/s:\\\:${langs}:" src/locale/locale.pri \
+ || die 'sed failed'
+}
+
+src_configure() {
+ eqmake4 arora.pro PREFIX="${D}/usr"
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ # don't pre-strip
+ sed -i "/strip/d" src/Makefile || die 'sed failed'
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die 'make install failed'
+ dodoc AUTHORS ChangeLog README
+}