summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/pyicq-t/ChangeLog10
-rw-r--r--net-im/pyicq-t/files/pyicq-t.service10
-rw-r--r--net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild54
3 files changed, 72 insertions, 2 deletions
diff --git a/net-im/pyicq-t/ChangeLog b/net-im/pyicq-t/ChangeLog
index 0d71bc4fcd72..d75822670c54 100644
--- a/net-im/pyicq-t/ChangeLog
+++ b/net-im/pyicq-t/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/pyicq-t
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.27 2013/09/14 23:01:18 hanno Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.28 2014/03/30 13:44:13 pacho Exp $
+
+*pyicq-t-0.8.1.5-r4 (30 Mar 2014)
+
+ 30 Mar 2014; Pacho Ramos <pacho@gentoo.org> +files/pyicq-t.service,
+ +pyicq-t-0.8.1.5-r4.ebuild:
+ Add unit file (#504150 by Michael Hampicke)
*pyicq-t-0.8.1.5-r3 (14 Sep 2013)
diff --git a/net-im/pyicq-t/files/pyicq-t.service b/net-im/pyicq-t/files/pyicq-t.service
new file mode 100644
index 000000000000..852ec13315af
--- /dev/null
+++ b/net-im/pyicq-t/files/pyicq-t.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=PyICQt is an ICQ transport for Jabber/XMPP
+
+[Service]
+ExecStart=INSPATH/pyicq-t.py -c /etc/jabber/pyicq-t.xml -l /var/log/jabber/pyicq-t.log
+User=jabber
+Group=jabber
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild b/net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild
new file mode 100644
index 000000000000..2e9aee38fd37
--- /dev/null
+++ b/net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild,v 1.1 2014/03/30 13:44:13 pacho Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit eutils python-single-r1 systemd
+
+MY_P="${P/pyicq-t/pyicqt}"
+DESCRIPTION="Python based jabber transport for ICQ"
+HOMEPAGE="http://code.google.com/p/pyicqt/"
+SRC_URI="http://pyicqt.googlecode.com/files/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="webinterface"
+
+DEPEND="net-im/jabber-base"
+RDEPEND="${DEPEND}
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-words[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ webinterface? ( >=dev-python/nevow-0.4.1[${PYTHON_USEDEP}] )
+ virtual/python-imaging[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python26-warnings.diff"
+ epatch "${FILESDIR}/${P}-pillow-imaging.patch"
+}
+
+src_install() {
+ python_moduleinto ${PN}
+ cp PyICQt.py ${PN}.py || die
+ python_domodule ${PN}.py data tools src
+
+ insinto /etc/jabber
+ newins config_example.xml ${PN}.xml
+ fperms 600 /etc/jabber/${PN}.xml
+ fowners jabber:jabber /etc/jabber/${PN}.xml
+ fperms 755 "$(python_get_sitedir)/${PN}/${PN}.py"
+ sed -i \
+ -e "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
+ -e "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
+ "${ED}/etc/jabber/${PN}.xml"
+
+ newinitd "${FILESDIR}/${PN}-0.8-initd-r1" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ sed -i -e "s:INSPATH:$(python_get_sitedir)/${PN}:" \
+ "${ED}/etc/init.d/${PN}" "${ED}/usr/lib/systemd/system/${PN}.service" || die
+
+ python_fix_shebang "${D}$(python_get_sitedir)/${PN}"
+}