summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/cryptlib/ChangeLog13
-rw-r--r--dev-libs/cryptlib/Manifest5
-rw-r--r--dev-libs/cryptlib/cryptlib-3.0.ebuild36
-rw-r--r--dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild37
-rw-r--r--dev-libs/cryptlib/files/digest-cryptlib-3.01
-rw-r--r--dev-libs/cryptlib/files/digest-cryptlib-3.1_beta041
6 files changed, 93 insertions, 0 deletions
diff --git a/dev-libs/cryptlib/ChangeLog b/dev-libs/cryptlib/ChangeLog
new file mode 100644
index 000000000000..eb8b09e48173
--- /dev/null
+++ b/dev-libs/cryptlib/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-libs/cryptlib
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/ChangeLog,v 1.1 2003/06/13 17:54:16 vapier Exp $
+
+*cryptlib-3.1_beta04 (13 Jun 2003)
+
+ 13 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
+
+*cryptlib-3.0 (13 Jun 2003)
+
+ 13 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/dev-libs/cryptlib/Manifest b/dev-libs/cryptlib/Manifest
new file mode 100644
index 000000000000..4e0d26fdb033
--- /dev/null
+++ b/dev-libs/cryptlib/Manifest
@@ -0,0 +1,5 @@
+MD5 0fdb286121d6d480968532f558148ecb cryptlib-3.0.ebuild 1022
+MD5 166402920c337c374a60b7fa0727dc1c ChangeLog 382
+MD5 83eab60d86883411374f08526c5fae6e cryptlib-3.1_beta04.ebuild 1057
+MD5 3230767344870b05b020a444fde77d23 files/digest-cryptlib-3.0 54
+MD5 7c7e549b4a508f53290cbb591b233f20 files/digest-cryptlib-3.1_beta04 60
diff --git a/dev-libs/cryptlib/cryptlib-3.0.ebuild b/dev-libs/cryptlib/cryptlib-3.0.ebuild
new file mode 100644
index 000000000000..90b78268c887
--- /dev/null
+++ b/dev-libs/cryptlib/cryptlib-3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.0.ebuild,v 1.1 2003/06/13 17:54:16 vapier Exp $
+
+DESCRIPTION="powerful security toolkit for adding encryption to software"
+HOMEPAGE="http://www.cs.auckland.ac.nz/~pgut001/cryptlib/"
+SRC_URI="ftp://ftp.franken.de/pub/crypt/cryptlib/cl${PV/./}.zip
+ doc? ( ftp://ftp.franken.de/pub/crypt/cryptlib/beta/manual.pdf )"
+
+LICENSE="Sleepycat"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="static doc"
+
+S=${WORKDIR}
+
+src_unpack() {
+ # cant use unpack cause we need the '-a' option
+ unzip -qoa ${DISTDIR}/${A}
+}
+
+src_compile() {
+ export SCFLAGS="-fpic -c -D__UNIX__ -DNDEBUG -I. ${CFLAGS}"
+ export CFLAGS="-c -D__UNIX__ -DNDEBUG -I. ${CFLAGS}"
+ if [ `use static` ] ; then
+ make CFLAGS="${CFLAGS}" SCFLAGS="${SCFLAGS}" || die "could not make static"
+ fi
+ make shared CFLAGS="${CFLAGS}" SCFLAGS="${SCFLAGS}" || die "could not make shared"
+}
+
+src_install() {
+ dolib.so libcl.so*
+ use static && dolib.a libcl.a
+ insinto /usr/include ; doins cryptlib.h
+ dodoc readme.1st
+}
diff --git a/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild b/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild
new file mode 100644
index 000000000000..68edb038ea0d
--- /dev/null
+++ b/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild,v 1.1 2003/06/13 17:54:16 vapier Exp $
+
+MY_PV=${PV/./}; MY_PV=${MY_PV/_/}
+DESCRIPTION="powerful security toolkit for adding encryption to software"
+HOMEPAGE="http://www.cs.auckland.ac.nz/~pgut001/cryptlib/"
+SRC_URI="ftp://ftp.franken.de/pub/crypt/cryptlib/beta/cl${MY_PV}.zip
+ doc? ( ftp://ftp.franken.de/pub/crypt/cryptlib/beta/manual.pdf )"
+
+LICENSE="Sleepycat"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="static doc"
+
+S=${WORKDIR}
+
+src_unpack() {
+ # cant use unpack cause we need the '-a' option
+ unzip -qoa ${DISTDIR}/${A}
+}
+
+src_compile() {
+ export SCFLAGS="-fpic -c -D__UNIX__ -DNDEBUG -I. ${CFLAGS}"
+ export CFLAGS="-c -D__UNIX__ -DNDEBUG -I. ${CFLAGS}"
+ if [ `use static` ] ; then
+ make CFLAGS="${CFLAGS}" SCFLAGS="${SCFLAGS}" || die "could not make static"
+ fi
+ make shared CFLAGS="${CFLAGS}" SCFLAGS="${SCFLAGS}" || die "could not make shared"
+}
+
+src_install() {
+ dolib.so libcl.so*
+ use static && dolib.a libcl.a
+ insinto /usr/include ; doins cryptlib.h
+ dodoc README
+}
diff --git a/dev-libs/cryptlib/files/digest-cryptlib-3.0 b/dev-libs/cryptlib/files/digest-cryptlib-3.0
new file mode 100644
index 000000000000..8d421eb3e4ca
--- /dev/null
+++ b/dev-libs/cryptlib/files/digest-cryptlib-3.0
@@ -0,0 +1 @@
+MD5 2bc946f094e0f91a50b61af68a0f6df5 cl30.zip 1775862
diff --git a/dev-libs/cryptlib/files/digest-cryptlib-3.1_beta04 b/dev-libs/cryptlib/files/digest-cryptlib-3.1_beta04
new file mode 100644
index 000000000000..566e77c9270c
--- /dev/null
+++ b/dev-libs/cryptlib/files/digest-cryptlib-3.1_beta04
@@ -0,0 +1 @@
+MD5 888b5497adf1c05518900297782af549 cl31beta04.zip 2095549