summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-fps/alephone/ChangeLog8
-rw-r--r--games-fps/alephone/alephone-20070819.ebuild73
-rw-r--r--games-fps/alephone/files/alephone-20070819-configure.patch44
-rw-r--r--games-fps/alephone/files/digest-alephone-200708193
4 files changed, 127 insertions, 1 deletions
diff --git a/games-fps/alephone/ChangeLog b/games-fps/alephone/ChangeLog
index b40c7dd6cee8..95bad99989e4 100644
--- a/games-fps/alephone/ChangeLog
+++ b/games-fps/alephone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/alephone
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.19 2007/07/05 20:04:34 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.20 2007/08/31 16:09:32 tupone Exp $
+
+*alephone-20070819 (31 Aug 2007)
+
+ 31 Aug 2007; <tupone@gentoo.org> +files/alephone-20070819-configure.patch,
+ +alephone-20070819.ebuild:
+ Version bump to 20070819 (0.18.1). Bug #182528 by Kai
05 Jul 2007; Markus Rothe <corsair@gentoo.org> alephone-20061228.ebuild:
Added ~ppc64; bug #183570
diff --git a/games-fps/alephone/alephone-20070819.ebuild b/games-fps/alephone/alephone-20070819.ebuild
new file mode 100644
index 000000000000..16a00bf23ad4
--- /dev/null
+++ b/games-fps/alephone/alephone-20070819.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20070819.ebuild,v 1.1 2007/08/31 16:09:32 tupone Exp $
+
+inherit autotools eutils games
+
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+SRC_URI="mirror://sourceforge/marathon/AlephOne-${PV}-nolibs.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="lua mad opengl smpeg sndfile speex vorbis"
+
+RDEPEND="opengl? ( virtual/opengl )
+ speex? ( media-libs/speex )
+ mad? ( media-libs/libmad )
+ vorbis? ( media-libs/libvorbis )
+ sndfile? ( media-libs/libsndfile )
+ smpeg? ( media-libs/smpeg )
+ media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/libsdl
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+S=${WORKDIR}/AlephOne-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed "s:GAMES_DATADIR:${GAMES_DATADIR}:g" \
+ "${FILESDIR}"/${PN}.sh > "${T}"/${PN}.sh \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-configure.patch
+ eautoreconf
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable lua) \
+ $(use_enable mad) \
+ $(use_enable opengl) \
+ $(use_enable smpeg) \
+ $(use_enable sndfile) \
+ $(use_enable speex) \
+ $(use_enable vorbis) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dogamesbin "${T}"/${PN}.sh || die "dogamesbin failed"
+ dodoc AUTHORS ChangeLog README docs/Cheat_Codes
+ dohtml docs/MML.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "Read the docs and install the data files accordingly to play."
+ echo
+ elog "If you only want to install one scenario, read"
+ elog "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Single_scenario_3"
+ elog "If you want to install multiple scenarios, read"
+ elog "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Multiple_scenarios_3"
+ echo
+}
diff --git a/games-fps/alephone/files/alephone-20070819-configure.patch b/games-fps/alephone/files/alephone-20070819-configure.patch
new file mode 100644
index 000000000000..1fc1a9b602cf
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20070819-configure.patch
@@ -0,0 +1,44 @@
+--- configure.ac.old 2007-08-31 02:12:32.000000000 +0200
++++ configure.ac 2007-08-31 02:17:50.000000000 +0200
+@@ -19,6 +19,8 @@
+ AC_ARG_ENABLE(sndfile, [ --enable-sndfile use libsndfile for decoding audio files [default=yes]], , enable_sndfile=yes)
+ AC_ARG_ENABLE(vorbis, [ --enable-vorbis enable ogg/vorbis music playback [default=yes]], , enable_vorbis=yes)
+ AC_ARG_ENABLE(lua, [ --enable-lua use built-in Lua scripting [default=yes]], , enable_lua=yes)
++AC_ARG_ENABLE(speex, , , enable_speex=yes)
++AC_ARG_ENABLE(smpeg, , , enable_smpeg=yes)
+
+ dnl Checks for programs.
+ AC_PROG_CC
+@@ -87,6 +88,7 @@
+ AC_CHECK_HEADER([boost/function.hpp], , [AC_MSG_ERROR([You need boost/function.hpp from the boost library to run Aleph One])])
+ AC_LANG_POP(C++)
+
++if [[ "x$enable_smpeg" = "xyes" ]]; then
+ dnl Check for SMPEG
+ AC_CHECK_HEADERS([smpeg/smpeg.h], [
+ AC_CHECK_LIB(smpeg, SMPEG_new, [
+@@ -94,6 +96,7 @@
+ AC_DEFINE(HAVE_SMPEG, 1, [SMPEG movie playback is enabled])
+ ])
+ ])
++fi
+
+ if [[ "x$enable_mad" = "xyes" ]]; then
+ dnl Check for libmad
+@@ -128,13 +129,16 @@
+ AC_DEFINE(HAVE_LUA, 1, [Lua support is enabled])
+ fi
+
++if [[ "x$enable_speex" = "xyes" ]]; then
+ dnl Check for Speex
++CPPFLAGS="$CPPFLAGS -I/usr/include/speex"
+ AC_CHECK_HEADERS(speex/speex.h, [
+ AC_CHECK_LIB(speex, speex_decoder_init, [
+ LIBS="-lspeex $LIBS"
+ AC_DEFINE(SPEEX, 1, [Speex support is enabled])
+ ])
+ ])
++fi
+
+ dnl Check for ALSA
+ AC_CHECK_HEADERS([alsa/asoundlib.h], [
diff --git a/games-fps/alephone/files/digest-alephone-20070819 b/games-fps/alephone/files/digest-alephone-20070819
new file mode 100644
index 000000000000..8bcd5b1462da
--- /dev/null
+++ b/games-fps/alephone/files/digest-alephone-20070819
@@ -0,0 +1,3 @@
+MD5 242b640c010ed25d9e614c504b91785d AlephOne-20070819-nolibs.tar.bz2 1735665
+RMD160 6815cb0485ee4370366898bb43b26875dd4615f2 AlephOne-20070819-nolibs.tar.bz2 1735665
+SHA256 966f2a474be3855343e53acb666874cd5ce061771593c6ddc77ac68dbb987c4d AlephOne-20070819-nolibs.tar.bz2 1735665