summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/acl/ChangeLog7
-rw-r--r--sys-apps/acl/acl-2.2.39.ebuild54
-rw-r--r--sys-apps/acl/files/digest-acl-2.2.393
3 files changed, 63 insertions, 1 deletions
diff --git a/sys-apps/acl/ChangeLog b/sys-apps/acl/ChangeLog
index 0b76cda6544d..d3d854b4efa9 100644
--- a/sys-apps/acl/ChangeLog
+++ b/sys-apps/acl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/acl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.53 2006/04/20 01:36:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.54 2006/08/10 03:14:23 vapier Exp $
+
+*acl-2.2.39 (10 Aug 2006)
+
+ 10 Aug 2006; Mike Frysinger <vapier@gentoo.org> +acl-2.2.39.ebuild:
+ Version bump.
20 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+files/acl-2.2.34-LDFLAGS.patch, acl-2.2.34.ebuild:
diff --git a/sys-apps/acl/acl-2.2.39.ebuild b/sys-apps/acl/acl-2.2.39.ebuild
new file mode 100644
index 000000000000..d0e61e5bba98
--- /dev/null
+++ b/sys-apps/acl/acl-2.2.39.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.39.ebuild,v 1.1 2006/08/10 03:14:23 vapier Exp $
+
+inherit eutils autotools
+
+MY_P="${PN}_${PV}-1"
+DESCRIPTION="Access control list utilities, libraries and headers"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz
+ ftp://xfs.org/mirror/SGI/cmd_tars/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND=">=sys-apps/attr-2.4
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.32-only-symlink-when-needed.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+ eautoconf
+}
+
+src_compile() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --libexecdir=/usr/$(get_libdir) \
+ --bindir=/bin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT="${D}" install install-dev install-lib || die
+ prepalldocs
+
+ # move shared libs to /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/libacl.so* "${D}"/$(get_libdir)/ || die
+ gen_usr_ldscript libacl.so
+}
diff --git a/sys-apps/acl/files/digest-acl-2.2.39 b/sys-apps/acl/files/digest-acl-2.2.39
new file mode 100644
index 000000000000..03ca0be73af2
--- /dev/null
+++ b/sys-apps/acl/files/digest-acl-2.2.39
@@ -0,0 +1,3 @@
+MD5 4edd450bbee60d6c4b3c51ae80499b00 acl_2.2.39-1.tar.gz 122091
+RMD160 5e6797b580c561a52d10b36d82587f8b80024a43 acl_2.2.39-1.tar.gz 122091
+SHA256 1c01909c1d293a8599b94f9bc75e41a07878067211f08c09c66b1070924b6066 acl_2.2.39-1.tar.gz 122091